设为首页收藏本站帮助中心
查看: 704|回复: 1
收起左侧

易语言MASM置入代码字节型/短整数型转换到到逻辑型数组 (高位在前,低位在前,无返回值)

[复制链接]
发表于 2021-12-12 08:16:09 | 显示全部楼层 |阅读模式
本帖最后由 EAX 于 2021-12-12 08:17 编辑
正在编译现行程序
正在检查重复名称...
正在预处理现行程序
正在进行名称连接...
正在统计需要编译的子程序
正在编译...
正在生成主程序入口代码
程序代码编译成功
正在封装易格式目的代码
开始运行被调试程序
* 数组:8{真,假,假,假,假,假,假,假} | 数组:8{假,假,假,假,假,假,假,真} | 1
* 数组:8{假,真,假,假,假,假,假,假} | 数组:8{假,假,假,假,假,假,真,假} | 2
* 数组:8{假,假,真,假,假,假,假,假} | 数组:8{假,假,假,假,假,真,假,假} | 4
* 数组:8{假,假,假,真,假,假,假,假} | 数组:8{假,假,假,假,真,假,假,假} | 8
* 数组:8{假,假,假,假,真,假,假,假} | 数组:8{假,假,假,真,假,假,假,假} | 16
* 数组:8{假,假,假,假,假,真,假,假} | 数组:8{假,假,真,假,假,假,假,假} | 32
* 数组:8{假,假,假,假,假,假,真,假} | 数组:8{假,真,假,假,假,假,假,假} | 64
* 数组:8{假,假,假,假,假,假,假,真} | 数组:8{真,假,假,假,假,假,假,假} | 128
* 数组:16{真,假,假,假,假,假,假,假,假,假,假,假,假,假,假,假} | 数组:16{假,假,假,假,假,假,假,假,假,假,假,假,假,假,假,真} | 1
* 数组:16{假,真,假,假,假,假,假,假,假,假,假,假,假,假,假,假} | 数组:16{假,假,假,假,假,假,假,假,假,假,假,假,假,假,真,假} | 2
* 数组:16{假,假,真,假,假,假,假,假,假,假,假,假,假,假,假,假} | 数组:16{假,假,假,假,假,假,假,假,假,假,假,假,假,真,假,假} | 4
* 数组:16{假,假,假,真,假,假,假,假,假,假,假,假,假,假,假,假} | 数组:16{假,假,假,假,假,假,假,假,假,假,假,假,真,假,假,假} | 8
* 数组:16{假,假,假,假,真,假,假,假,假,假,假,假,假,假,假,假} | 数组:16{假,假,假,假,假,假,假,假,假,假,假,真,假,假,假,假} | 16
* 数组:16{假,假,假,假,假,真,假,假,假,假,假,假,假,假,假,假} | 数组:16{假,假,假,假,假,假,假,假,假,假,真,假,假,假,假,假} | 32
* 数组:16{假,假,假,假,假,假,真,假,假,假,假,假,假,假,假,假} | 数组:16{假,假,假,假,假,假,假,假,假,真,假,假,假,假,假,假} | 64
* 数组:16{假,假,假,假,假,假,假,真,假,假,假,假,假,假,假,假} | 数组:16{假,假,假,假,假,假,假,假,真,假,假,假,假,假,假,假} | 128
* 数组:16{假,假,假,假,假,假,假,假,真,假,假,假,假,假,假,假} | 数组:16{假,假,假,假,假,假,假,真,假,假,假,假,假,假,假,假} | 256
* 数组:16{假,假,假,假,假,假,假,假,假,真,假,假,假,假,假,假} | 数组:16{假,假,假,假,假,假,真,假,假,假,假,假,假,假,假,假} | 512
* 数组:16{假,假,假,假,假,假,假,假,假,假,真,假,假,假,假,假} | 数组:16{假,假,假,假,假,真,假,假,假,假,假,假,假,假,假,假} | 1024
* 数组:16{假,假,假,假,假,假,假,假,假,假,假,真,假,假,假,假} | 数组:16{假,假,假,假,真,假,假,假,假,假,假,假,假,假,假,假} | 2048
* 数组:16{假,假,假,假,假,假,假,假,假,假,假,假,真,假,假,假} | 数组:16{假,假,假,真,假,假,假,假,假,假,假,假,假,假,假,假} | 4096
* 数组:16{假,假,假,假,假,假,假,假,假,假,假,假,假,真,假,假} | 数组:16{假,假,真,假,假,假,假,假,假,假,假,假,假,假,假,假} | 8192
* 数组:16{假,假,假,假,假,假,假,假,假,假,假,假,假,假,真,假} | 数组:16{假,真,假,假,假,假,假,假,假,假,假,假,假,假,假,假} | 16384
* 数组:16{假,假,假,假,假,假,假,假,假,假,假,假,假,假,假,真} | 数组:16{真,假,假,假,假,假,假,假,假,假,假,假,假,假,假,假} | -32768
被调试易程序运行完毕

1.png
  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 数组_低位在前, 逻辑型, , "0"
  9. .局部变量 数组_高位在前, 逻辑型, , "0"
  10. .局部变量 字节, 字节型
  11. .局部变量 短整数, 短整数型

  12. 字节 = 1
  13. .计次循环首 (8, )
  14.     字节型_到逻辑型数组_低位在前 (字节, 数组_低位在前)
  15.     字节型_到逻辑型数组_高位在前 (字节, 数组_高位在前)
  16.     调试输出 (数组_低位在前, 数组_高位在前, 字节)
  17.     字节 = 左移 (字节, 1)
  18. .计次循环尾 ()
  19. 短整数 = 1
  20. .计次循环首 (16, )
  21.     短整数型_到逻辑型数组_低位在前 (短整数, 数组_低位在前)
  22.     短整数型_到逻辑型数组_高位在前 (短整数, 数组_高位在前)
  23.     调试输出 (数组_低位在前, 数组_高位在前, 短整数)
  24.     短整数 = 左移 (短整数, 1)
  25. .计次循环尾 ()

  26. .子程序 字节型_到逻辑型数组_低位在前, , 公开
  27. .参数 输入字节, 字节型
  28. .参数 输出8位, 逻辑型, 参考 数组

  29. 重定义数组 (输出8位, 真, 8)
  30. 置入代码 ({ 80, 83, 81, 82, 139, 69, 8, 139, 93, 12, 139, 27, 131, 195, 8, 51, 201, 235, 13, 186, 1, 0, 0, 0, 35, 208, 209, 232, 137, 20, 139, 65, 131, 249, 8, 114, 238, 90, 89, 91, 88 })
  31. ' push eax
  32. ' push ebx
  33. ' push ecx
  34. ' push edx
  35. ' mov eax,[ebp+8]
  36. ' mov ebx,[ebp+12]
  37. ' mov ebx,[ebx]
  38. ' add ebx,8
  39. ' xor ecx,ecx
  40. ' .while ecx < 8
  41. ' mov edx,1
  42. ' and edx,eax
  43. ' shr eax,1
  44. ' mov [ebx+ecx*4],edx
  45. ' inc ecx
  46. ' .endw
  47. ' pop edx
  48. ' pop ecx
  49. ' pop ebx
  50. ' pop eax


  51. .子程序 字节型_到逻辑型数组_高位在前, , 公开
  52. .参数 输入字节, 字节型
  53. .参数 输出8位, 逻辑型, 参考 数组

  54. 重定义数组 (输出8位, 真, 8)
  55. 置入代码 ({ 80, 83, 81, 82, 139, 69, 8, 139, 93, 12, 139, 27, 131, 195, 8, 185, 8, 0, 0, 0, 235, 13, 73, 186, 1, 0, 0, 0, 35, 208, 209, 232, 137, 20, 139, 11, 201, 117, 239, 90, 89, 91, 88 })
  56. ' push eax
  57. ' push ebx
  58. ' push ecx
  59. ' push edx
  60. ' mov eax,[ebp+8]
  61. ' mov ebx,[ebp+12]
  62. ' mov ebx,[ebx]
  63. ' add ebx,8
  64. ' mov ecx,8
  65. ' .while ecx
  66. ' dec ecx
  67. ' mov edx,1
  68. ' and edx,eax
  69. ' shr eax,1
  70. ' mov [ebx+ecx*4],edx
  71. ' .endw
  72. ' pop edx
  73. ' pop ecx
  74. ' pop ebx
  75. ' pop eax


  76. .子程序 短整数型_到逻辑型数组_低位在前, , 公开
  77. .参数 输入短整数, 短整数型
  78. .参数 输出16位, 逻辑型, 参考 数组

  79. 重定义数组 (输出16位, 真, 16)
  80. 置入代码 ({ 80, 83, 81, 82, 139, 69, 8, 139, 93, 12, 139, 27, 131, 195, 8, 51, 201, 235, 13, 186, 1, 0, 0, 0, 35, 208, 209, 232, 137, 20, 139, 65, 131, 249, 16, 114, 238, 90, 89, 91, 88 })
  81. ' push eax
  82. ' push ebx
  83. ' push ecx
  84. ' push edx
  85. ' mov eax,[ebp+8]
  86. ' mov ebx,[ebp+12]
  87. ' mov ebx,[ebx]
  88. ' add ebx,8
  89. ' xor ecx,ecx
  90. ' .while ecx < 16
  91. ' mov edx,1
  92. ' and edx,eax
  93. ' shr eax,1
  94. ' mov [ebx+ecx*4],edx
  95. ' inc ecx
  96. ' .endw
  97. ' pop edx
  98. ' pop ecx
  99. ' pop ebx
  100. ' pop eax


  101. .子程序 短整数型_到逻辑型数组_高位在前, , 公开
  102. .参数 输入短整数, 短整数型
  103. .参数 输出16位, 逻辑型, 参考 数组

  104. 重定义数组 (输出16位, 真, 16)
  105. 置入代码 ({ 80, 83, 81, 82, 139, 69, 8, 139, 93, 12, 139, 27, 131, 195, 8, 185, 16, 0, 0, 0, 235, 13, 73, 186, 1, 0, 0, 0, 35, 208, 209, 232, 137, 20, 139, 11, 201, 117, 239, 90, 89, 91, 88 })
  106. ' push eax
  107. ' push ebx
  108. ' push ecx
  109. ' push edx
  110. ' mov eax,[ebp+8]
  111. ' mov ebx,[ebp+12]
  112. ' mov ebx,[ebx]
  113. ' add ebx,8
  114. ' mov ecx,16
  115. ' .while ecx
  116. ' dec ecx
  117. ' mov edx,1
  118. ' and edx,eax
  119. ' shr eax,1
  120. ' mov [ebx+ecx*4],edx
  121. ' .endw
  122. ' pop edx
  123. ' pop ecx
  124. ' pop ebx
  125. ' pop eax

复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则