设为首页收藏本站帮助中心
查看: 362|回复: 0
收起左侧

易语言调用CMD的 copy /b 命令实现将多个小文件合并成一个大文件 (返回逻辑型)

[复制链接]
发表于 2021-12-31 08:53:04 | 显示全部楼层 |阅读模式

孩子辍学不想上学打工咋办?
来我这免费学:易语言、51单片机、FPGA(IC设计)、PHP Dsicuz! 程序修改、MASM汇编,包教包会,学废为止。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png
  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. 输出调试文本 (合并文件 ({ “1.txt”, “2.txt”, “3.txt”, “4.txt” }, “out.txt”))


  8. .子程序 合并文件, 逻辑型, 公开
  9. .参数 输入文件名, 文本型, 数组
  10. .参数 输出文件名, 文本型
  11. .局部变量 文件数, 整数型
  12. .局部变量 计数, 整数型
  13. .局部变量 命令行, 文本型
  14. .局部变量 文件名, 文本型
  15. .局部变量 错误输出, 文本型
  16. .局部变量 标准输出, 文本型

  17. 文件数 = 取数组成员数 (输入文件名)
  18. .如果真 (文件数 = 0)
  19.     返回 (假)
  20. .如果真结束
  21. 命令行 = “cmd /c copy /b ”
  22. .计次循环首 (文件数, 计数)
  23.     文件名 = 输入文件名 [计数]
  24.     .如果真 (文件是否存在 (文件名) = 假)
  25.         返回 (假)
  26.     .如果真结束
  27.     .如果 (计数 = 文件数)
  28.         命令行 = 命令行 + #引号 + 文件名 + #引号 + “ ” + #引号 + 输出文件名 + #引号
  29.     .否则
  30.         命令行 = 命令行 + #引号 + 文件名 + #引号 + “+”
  31.     .如果结束

  32. .计次循环尾 ()

  33. .判断开始 (运行控制台程序 (命令行, 标准输出, 错误输出, ) = 假)
  34.     返回 (假)
  35. .判断 (错误输出 ≠ “” 或 标准输出 = “”)
  36.     返回 (假)
  37. .默认

  38. .判断结束
  39. 返回 (文件是否存在 (输出文件名))
复制代码

相关帖子

本站源码使用前请注意检查,如有问题请点击右下角举报,将在24小时内得到答复。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则