设为首页收藏本站帮助中心
查看: 441|回复: 0
收起左侧

易语言 两种方法实现将字节集数据添加到文件末尾 (返回逻辑型)

[复制链接]
发表于 2022-1-1 18:54:56 | 显示全部楼层 |阅读模式
1.png
  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序


  7. 输出调试文本 (字节集_添加到文件末尾 (“test.txt”, 到字节集 (“Hello World!” + #换行符)))

  8. .子程序 字节集_添加到文件末尾, 逻辑型, 公开
  9. .参数 文件名, 文本型
  10. .参数 欲添加文件的数据, 字节集
  11. .局部变量 文件号, 整数型

  12. .如果真 (文件是否存在 (文件名) = 假)
  13.     返回 (写到文件 (文件名, 欲添加文件的数据))
  14. .如果真结束
  15. 文件号 = 打开文件 (文件名, #写出, #禁止写)
  16. .判断开始 (文件号 = 0)
  17.     返回 (字节集_添加到文件末尾_CMD (文件名, 欲添加文件的数据))
  18. .判断 (移动读写位置 (文件号, #文件尾, 0) = 假)
  19.     关闭文件 (文件号)
  20.     返回 (字节集_添加到文件末尾_CMD (文件名, 欲添加文件的数据))
  21. .判断 (写出字节集 (文件号, 欲添加文件的数据) = 假)
  22.     关闭文件 (文件号)
  23.     返回 (字节集_添加到文件末尾_CMD (文件名, 欲添加文件的数据))
  24. .默认

  25. .判断结束
  26. 关闭文件 (文件号)
  27. 返回 (真)

  28. .子程序 字节集_添加到文件末尾_CMD, 逻辑型, 公开
  29. .参数 文件名, 文本型
  30. .参数 欲添加文件的数据, 字节集
  31. .局部变量 命令行, 文本型
  32. .局部变量 临时, 文本型
  33. .局部变量 标准输出, 文本型
  34. .局部变量 错误输出, 文本型

  35. .如果真 (文件是否存在 (文件名) = 假)
  36.     返回 (写到文件 (文件名, 欲添加文件的数据))
  37. .如果真结束
  38. 临时 = 取临时文件名 ()
  39. 命令行 = “cmd /c copy /b ” + #引号 + 文件名 + #引号 + “+” + #引号 + 临时 + #引号 + “ ” + #引号 + 文件名 + #引号
  40. .判断开始 (写到文件 (临时, 欲添加文件的数据) = 假)
  41.     删除文件 (临时)
  42.     返回 (假)
  43. .判断 (运行控制台程序 (命令行, 标准输出, 错误输出, ) = 假)
  44.     删除文件 (临时)
  45.     返回 (假)
  46. .判断 (错误输出 ≠ “”)
  47.     删除文件 (临时)
  48.     返回 (假)
  49. .默认

  50. .判断结束
  51. 删除文件 (临时)
  52. 返回 (真)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则