设为首页收藏本站帮助中心
查看: 347|回复: 0
收起左侧

易语言MASM置入代码检测字节集是否为纯数字(返回逻辑型,不支持负数、小数等其他符号)

[复制链接]
发表于 2022-2-5 12:27:45 | 显示全部楼层 |阅读模式
1.png
  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. 输出调试文本 (字节集_是否为数字 ({  }))
  8. 输出调试文本 (字节集_是否为数字 ({ 48, 49, 57 }))
  9. 输出调试文本 (字节集_是否为数字 (到字节集 (“0123456789”)))
  10. 输出调试文本 (字节集_是否为数字 (到字节集 (“1a”)))
  11. 输出调试文本 (字节集_是否为数字 (到字节集 (“12345”)))
  12. 输出调试文本 (字节集_是否为数字 (到字节集 (“abc123”)))


  13. .子程序 字节集_是否为数字, 逻辑型, 公开
  14. .参数 字节集, 字节集

  15. 置入代码 ({ 83, 81, 82, 139, 69, 8, 11, 192, 117, 2, 235, 53, 139, 0, 11, 192, 117, 2, 235, 45, 139, 88, 4, 11, 219, 117, 4, 51, 192, 235, 34, 131, 192, 8, 51, 201, 235, 18, 138, 20, 8, 128, 250, 48, 114, 5, 128, 250, 57, 118, 4, 51, 192, 235, 10, 65, 59, 203, 114, 234, 184, 1, 0, 0, 0, 90, 89, 91, 201, 194, 4, 0 })
  16. ' push ebx
  17. ' push ecx
  18. ' push edx
  19. ' mov eax,[ebp+8]
  20. ' .if !eax
  21. ' jmp ASM_END
  22. ' .endif
  23. ' mov eax,[eax]
  24. ' .if !eax
  25. ' jmp ASM_END
  26. ' .endif
  27. ' mov ebx,[eax+4]
  28. ' .if !ebx
  29. ' xor eax,eax
  30. ' jmp ASM_END
  31. ' .endif
  32. ' add eax,8
  33. ' xor ecx,ecx
  34. ' .while ecx < ebx
  35. ' mov dl,[ecx+eax]
  36. ' .if dl < 48 || dl > 57
  37. ' xor eax,eax
  38. ' jmp ASM_END
  39. ' .endif
  40. ' inc ecx
  41. ' .endw
  42. ' mov eax,1
  43. ' ASM_END:
  44. ' pop edx
  45. ' pop ecx
  46. ' pop ebx
  47. ' leave
  48. ' retn 4

  49. 返回 (假)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则