设为首页收藏本站帮助中心
查看: 590|回复: 0
收起左侧

易语言MASM置入代码实现判断一段字节集数据是否为数字或大小写字母组成 (返回逻辑型)

[复制链接]
发表于 2022-2-6 11:15:51 | 显示全部楼层 |阅读模式
1.png
  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序


  7. 输出调试文本 (字节集_是否为数字大小写字母 (到字节集 (“123ABCabc”)))
  8. 输出调试文本 (字节集_是否为数字大小写字母 (到字节集 (“”)))
  9. 输出调试文本 (字节集_是否为数字大小写字母 (到字节集 (“12345”)))
  10. 输出调试文本 (字节集_是否为数字大小写字母 (到字节集 (“09AZaz”)))
  11. 输出调试文本 (字节集_是否为数字大小写字母 (到字节集 (“abcde”)))
  12. 输出调试文本 (字节集_是否为数字大小写字母 (到字节集 (“ABCDE”)))
  13. 输出调试文本 (字节集_是否为数字大小写字母 (到字节集 (“123@”)))

  14. .子程序 字节集_是否为数字大小写字母, 逻辑型, , 只允许出现数字或大小写字母
  15. .参数 数据, 字节集

  16. 置入代码 ({ 83, 81, 82, 139, 69, 8, 11, 192, 117, 2, 235, 79, 139, 0, 11, 192, 117, 2, 235, 71, 139, 88, 4, 11, 219, 117, 4, 51, 192, 235, 60, 131, 192, 8, 51, 201, 235, 44, 138, 20, 8, 128, 250, 48, 114, 7, 128, 250, 57, 119, 2, 235, 28, 128, 250, 65, 114, 7, 128, 250, 90, 119, 2, 235, 16, 128, 250, 97, 114, 7, 128, 250, 122, 119, 2, 235, 4, 51, 192, 235, 10, 65, 59, 203, 114, 208, 184, 1, 0, 0, 0, 90, 89, 91, 201, 194, 4, 0 })
  17. ' push ebx
  18. ' push ecx
  19. ' push edx
  20. ' mov eax,[ebp+8]
  21. ' .if !eax
  22. ' jmp ASM_END
  23. ' .endif
  24. ' mov eax,[eax]
  25. ' .if !eax
  26. ' jmp ASM_END
  27. ' .endif
  28. ' mov ebx,[eax+4]
  29. ' .if !ebx
  30. ' xor eax,eax
  31. ' jmp ASM_END
  32. ' .endif
  33. ' add eax,8
  34. ' xor ecx,ecx
  35. ' .while ecx < ebx
  36. ' mov dl,[ecx+eax]
  37. ' .if dl >= 48 && dl <= 57
  38. ' .elseif dl >= 65 && dl <= 90
  39. ' .elseif dl >= 97 && dl <= 122
  40. ' .else
  41. ' xor eax,eax
  42. ' jmp ASM_END
  43. ' .endif
  44. ' inc ecx
  45. ' .endw
  46. ' mov eax,1
  47. ' ASM_END:
  48. ' pop edx
  49. ' pop ecx
  50. ' pop ebx
  51. ' leave
  52. ' retn 4

  53. 返回 (假)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则