设为首页收藏本站帮助中心
查看: 577|回复: 0
收起左侧

易语言MASM置入代码判断字节集是否全部为数字、大小写字母、半角符号组成(返回逻辑型)

[复制链接]
发表于 2022-2-7 19:35:18 | 显示全部楼层 |阅读模式
1.png
  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (字节集_是否为数字大小写字母符号 (到字节集 (“HelloWorld!”)))
  9. 输出调试文本 (字节集_是否为数字大小写字母符号 (到字节集 (“123ABCabc!@#”)))
  10. 输出调试文本 (字节集_是否为数字大小写字母符号 (到字节集 (“!!<?@#<%$@#^>$*<%^&?>%^&^>”)))
  11. 输出调试文本 (字节集_是否为数字大小写字母符号 (到字节集 (“1 2 3”)))
  12. 输出调试文本 (字节集_是否为数字大小写字母符号 (到字节集 (“中文字符串”)))
  13. 输出调试文本 (字节集_是否为数字大小写字母符号 (到字节集 (“”)))



  14. .子程序 字节集_是否为数字大小写字母符号, 逻辑型, , 只允许出现 数字、大小写字母、32种半角符号 不允许出现中文或空格 0字节返回假
  15. .参数 数据, 字节集

  16. 置入代码 ({ 83, 81, 82, 139, 69, 8, 11, 192, 117, 2, 235, 53, 139, 0, 11, 192, 117, 2, 235, 45, 139, 88, 4, 11, 219, 117, 4, 51, 192, 235, 34, 131, 192, 8, 51, 201, 235, 18, 138, 20, 8, 128, 250, 33, 114, 5, 128, 250, 126, 118, 4, 51, 192, 235, 10, 65, 59, 203, 114, 234, 184, 1, 0, 0, 0, 90, 89, 91, 201, 194, 4, 0 })
  17. ' push ebx
  18. ' push ecx
  19. ' push edx
  20. ' mov eax,[ebp+8]
  21. ' .if !eax
  22. ' jmp ASM_END
  23. ' .endif
  24. ' mov eax,[eax]
  25. ' .if !eax
  26. ' jmp ASM_END
  27. ' .endif
  28. ' mov ebx,[eax+4]
  29. ' .if !ebx
  30. ' xor eax,eax
  31. ' jmp ASM_END
  32. ' .endif
  33. ' add eax,8
  34. ' xor ecx,ecx
  35. ' .while ecx < ebx
  36. ' mov dl,[ecx+eax]
  37. ' .if dl < 33 || dl > 126
  38. ' xor eax,eax
  39. ' jmp ASM_END
  40. ' .endif
  41. ' inc ecx
  42. ' .endw
  43. ' mov eax,1
  44. ' ASM_END:
  45. ' pop edx
  46. ' pop ecx
  47. ' pop ebx
  48. ' leave
  49. ' retn 4
  50. 返回 (假)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则