设为首页收藏本站帮助中心
查看: 548|回复: 0
收起左侧

易语言MASM置入代码判断文本型密码是否为数字、大小写字母、半角符号组成(返回逻辑型)

[复制链接]
发表于 2022-2-10 18:20:04 | 显示全部楼层 |阅读模式
1.png
  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (文本型密码_是否合法 (“12345!@#”))
  9. 输出调试文本 (文本型密码_是否合法 (“12345”))
  10. 输出调试文本 (文本型密码_是否合法 (“~!@#$%^&*()_+123AbcABC”))
  11. 输出调试文本 (文本型密码_是否合法 (“”))
  12. 输出调试文本 (文本型密码_是否合法 (“Hello123 !@3”))
  13. 输出调试文本 (文本型密码_是否合法 (“Hello123中文”))
  14. 输出调试文本 (文本型密码_是否合法 (“0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz”))

  15. .子程序 文本型密码_是否合法, 逻辑型, 公开, 密码只允许出现:大写字母、小写字母、数字、半角符号 不允许出现空格、中文 空文本返回假
  16. .参数 密码, 文本型

  17. 置入代码 ({ 83, 139, 69, 8, 11, 192, 117, 2, 235, 42, 139, 0, 11, 192, 117, 2, 235, 34, 50, 255, 138, 24, 10, 219, 117, 4, 235, 21, 235, 14, 128, 251, 33, 114, 5, 128, 251, 126, 118, 4, 51, 192, 235, 8, 183, 1, 64, 235, 227, 15, 182, 199, 91, 201, 194, 4, 0 })
  18. ' push ebx
  19. ' mov eax,[ebp+8]
  20. ' .if !eax
  21. ' jmp ASM_END
  22. ' .endif
  23. ' mov eax,[eax]
  24. ' .if !eax
  25. ' jmp ASM_END
  26. ' .endif
  27. ' xor bh,bh
  28. ' .while 1
  29. ' mov bl,[eax]
  30. ' .if !bl
  31. ' .break
  32. ' .elseif bl < 33 || bl > 126
  33. ' xor eax,eax
  34. ' jmp ASM_END
  35. ' .endif
  36. ' mov bh,1
  37. ' inc eax
  38. ' .endw
  39. ' movzx eax,bh
  40. ' ASM_END:
  41. ' pop ebx
  42. ' leave
  43. ' retn 4

  44. 返回 (假)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则