设为首页收藏本站帮助中心
查看: 1002|回复: 0
收起左侧

易语言MASM置入代码实现整数型与子程序指针的 (等于/不等于比较) (返回逻辑型)

[复制链接]
发表于 2022-4-8 18:56:59 | 显示全部楼层 |阅读模式
1.png
  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 整数, 整数型
  8. .局部变量 指针, 子程序指针

  9. 指针 = &整数型与子程序指针_等于
  10. 整数 = 到整数 (指针)
  11. 输出调试文本 (整数型与子程序指针_等于 (整数, 指针))
  12. 整数 = 0
  13. 输出调试文本 (整数型与子程序指针_不等于 (整数, 指针))

  14. .子程序 整数型与子程序指针_等于, 逻辑型, 公开
  15. .参数 整数, 整数型
  16. .参数 指针, 子程序指针

  17. 置入代码 ({ 139, 69, 8, 59, 69, 12, 117, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  18. ' mov eax,[ebp+8]
  19. ' .if eax == [ebp+12]
  20. ' mov eax,1
  21. ' .else
  22. ' xor eax,eax
  23. ' .endif
  24. ' leave
  25. ' retn 8
  26. 返回 (假)

  27. .子程序 整数型与子程序指针_不等于, 逻辑型, 公开
  28. .参数 整数, 整数型
  29. .参数 指针, 子程序指针

  30. 置入代码 ({ 139, 69, 8, 59, 69, 12, 116, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  31. ' mov eax,[ebp+8]
  32. ' .if eax != [ebp+12]
  33. ' mov eax,1
  34. ' .else
  35. ' xor eax,eax
  36. ' .endif
  37. ' leave
  38. ' retn 8
  39. 返回 (假)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则