设为首页收藏本站帮助中心
查看: 86|回复: 0
收起左侧

易语言MASM置入代码实现有符号字节型的大于/小于/大于等于/小于等于比较 (返回逻辑型)

[复制链接]
发表于 2022-4-21 10:21:21 | 显示全部楼层 |阅读模式

孩子辍学不想上学打工咋办?
来我这免费学:易语言、51单片机、FPGA(IC设计)、PHP Dsicuz! 程序修改、MASM汇编,包教包会,学废为止。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png
  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (有符号字节型_大于 (1, 255))  ' 255有符号为:-1
  9. 输出调试文本 (有符号字节型_小于 (255, 1))
  10. 输出调试文本 (有符号字节型_大于等于 (0, 255))
  11. 输出调试文本 (有符号字节型_小于等于 (123, 123))


  12. .子程序 有符号字节型_大于, 逻辑型, 公开
  13. .参数 被比较值, 字节型
  14. .参数 比较值, 字节型

  15. 置入代码 ({ 138, 69, 8, 58, 69, 12, 126, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  16. ' mov al,[ebp+8]
  17. ' .if sbyte ptr al > [ebp+12]
  18. ' mov eax,1
  19. ' .else
  20. ' xor eax,eax
  21. ' .endif
  22. ' leave
  23. ' retn 8
  24. 返回 (假)

  25. .子程序 有符号字节型_小于, 逻辑型, 公开
  26. .参数 被比较值, 字节型
  27. .参数 比较值, 字节型

  28. 置入代码 ({ 138, 69, 8, 58, 69, 12, 125, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  29. ' mov al,[ebp+8]
  30. ' .if sbyte ptr al < [ebp+12]
  31. ' mov eax,1
  32. ' .else
  33. ' xor eax,eax
  34. ' .endif
  35. ' leave
  36. ' retn 8
  37. 返回 (假)

  38. .子程序 有符号字节型_大于等于, 逻辑型, 公开
  39. .参数 被比较值, 字节型
  40. .参数 比较值, 字节型

  41. 置入代码 ({ 138, 69, 8, 58, 69, 12, 124, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  42. ' mov al,[ebp+8]
  43. ' .if sbyte ptr al >= [ebp+12]
  44. ' mov eax,1
  45. ' .else
  46. ' xor eax,eax
  47. ' .endif
  48. ' leave
  49. ' retn 8
  50. 返回 (假)

  51. .子程序 有符号字节型_小于等于, 逻辑型, 公开
  52. .参数 被比较值, 字节型
  53. .参数 比较值, 字节型

  54. 置入代码 ({ 138, 69, 8, 58, 69, 12, 127, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  55. ' mov al,[ebp+8]
  56. ' .if sbyte ptr al <= [ebp+12]
  57. ' mov eax,1
  58. ' .else
  59. ' xor eax,eax
  60. ' .endif
  61. ' leave
  62. ' retn 8
  63. 返回 (假)
复制代码

相关帖子

本站源码使用前请注意检查,如有问题请点击右下角举报,将在24小时内得到答复。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则