设为首页收藏本站帮助中心
查看: 344|回复: 0
收起左侧

易语言MASM置入代码实现短整数型的大于/小于/大于等于/小于等于比较 (返回逻辑型)

[复制链接]
发表于 2022-4-26 08:41:04 | 显示全部楼层 |阅读模式
1.png
  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码

  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. 输出调试文本 (短整数型_大于 (-1, 0))
  8. 输出调试文本 (短整数型_小于 (-1, -123))
  9. 输出调试文本 (短整数型_大于等于 (0, -1))
  10. 输出调试文本 (短整数型_小于等于 (0, -1))


  11. .子程序 短整数型_大于, 逻辑型, 公开
  12. .参数 被比较值, 短整数型
  13. .参数 比较值, 短整数型

  14. 置入代码 ({ 102, 139, 69, 8, 102, 59, 69, 12, 126, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  15. ' mov ax,[ebp+8]
  16. ' .if sword ptr ax > [ebp+12]
  17. ' mov eax,1
  18. ' .else
  19. ' xor eax,eax
  20. ' .endif
  21. ' leave
  22. ' retn 8

  23. 返回 (假)

  24. .子程序 短整数型_小于, 逻辑型, 公开
  25. .参数 被比较值, 短整数型
  26. .参数 比较值, 短整数型

  27. 置入代码 ({ 102, 139, 69, 8, 102, 59, 69, 12, 125, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  28. ' mov ax,[ebp+8]
  29. ' .if sword ptr ax < [ebp+12]
  30. ' mov eax,1
  31. ' .else
  32. ' xor eax,eax
  33. ' .endif
  34. ' leave
  35. ' retn 8

  36. 返回 (假)

  37. .子程序 短整数型_大于等于, 逻辑型, 公开
  38. .参数 被比较值, 短整数型
  39. .参数 比较值, 短整数型

  40. 置入代码 ({ 102, 139, 69, 8, 102, 59, 69, 12, 124, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  41. ' mov ax,[ebp+8]
  42. ' .if sword ptr ax >= [ebp+12]
  43. ' mov eax,1
  44. ' .else
  45. ' xor eax,eax
  46. ' .endif
  47. ' leave
  48. ' retn 8

  49. 返回 (假)

  50. .子程序 短整数型_小于等于, 逻辑型, 公开
  51. .参数 被比较值, 短整数型
  52. .参数 比较值, 短整数型

  53. 置入代码 ({ 102, 139, 69, 8, 102, 59, 69, 12, 127, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  54. ' mov ax,[ebp+8]
  55. ' .if sword ptr ax <= [ebp+12]
  56. ' mov eax,1
  57. ' .else
  58. ' xor eax,eax
  59. ' .endif
  60. ' leave
  61. ' retn 8

  62. 返回 (假)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则