设为首页收藏本站帮助中心
查看: 56|回复: 0
收起左侧

易语言MASM置入代码实现短整数型的 min(A,B) / max(A,B) 函数运算 (返回短整数型)

[复制链接]
发表于 2022-4-30 17:19:07 | 显示全部楼层 |阅读模式

孩子辍学不想上学打工咋办?
来我这免费学:易语言、51单片机、FPGA(IC设计)、PHP Dsicuz! 程序修改、MASM汇编,包教包会,学废为止。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png
  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. 输出调试文本 (短整数型_min (123, -124))
  8. 输出调试文本 (短整数型_max (666, 0))

  9. .子程序 短整数型_min, 短整数型, 公开, A、B谁小返回谁
  10. .参数 A, 短整数型
  11. .参数 B, 短整数型

  12. 置入代码 ({ 102, 83, 102, 139, 69, 8, 102, 139, 93, 12, 102, 59, 216, 125, 3, 102, 139, 195, 15, 183, 192, 102, 91, 201, 194, 8, 0 })
  13. ' push bx
  14. ' mov ax,[ebp+8]
  15. ' mov bx,[ebp+12]
  16. ' .if sword ptr bx < ax
  17. ' mov ax,bx
  18. ' .endif
  19. ' movzx eax,ax
  20. ' pop bx
  21. ' leave
  22. ' retn 8
  23. 返回 (0)

  24. .子程序 短整数型_max, 短整数型, 公开, A、B谁大返回谁
  25. .参数 A, 短整数型
  26. .参数 B, 短整数型

  27. 置入代码 ({ 102, 83, 102, 139, 69, 8, 102, 139, 93, 12, 102, 59, 216, 126, 3, 102, 139, 195, 15, 183, 192, 102, 91, 201, 194, 8, 0 })
  28. ' push bx
  29. ' mov ax,[ebp+8]
  30. ' mov bx,[ebp+12]
  31. ' .if sword ptr bx > ax
  32. ' mov ax,bx
  33. ' .endif
  34. ' movzx eax,ax
  35. ' pop bx
  36. ' leave
  37. ' retn 8
  38. 返回 (0)
复制代码

相关帖子

本站源码使用前请注意检查,如有问题请点击右下角举报,将在24小时内得到答复。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则