设为首页收藏本站帮助中心
查看: 223|回复: 0
收起左侧

易语言MASM置入代码实现字节型的 min(A,B) / max(A,B) 函数运算 (返回字节型)

[复制链接]
发表于 2022-5-19 08:04:57 | 显示全部楼层 |阅读模式
1.png
  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (字节型_min (123, 234))
  9. 输出调试文本 (字节型_min (234, 123))
  10. 输出调试文本 (字节型_max (123, 234))
  11. 输出调试文本 (字节型_max (234, 123))

  12. .子程序 字节型_min, 字节型, 公开, A、B谁小返回谁
  13. .参数 A, 字节型
  14. .参数 B, 字节型

  15. 置入代码 ({ 138, 69, 8, 138, 101, 12, 56, 196, 115, 2, 138, 196, 15, 182, 192, 201, 194, 8, 0 })
  16. ' mov al,[ebp+8]
  17. ' mov ah,[ebp+12]
  18. ' .if ah < al
  19. ' mov al,ah
  20. ' .endif
  21. ' movzx eax,al
  22. ' leave
  23. ' retn 8

  24. 返回 (0)

  25. .子程序 字节型_max, 字节型, 公开, A、B谁大返回谁
  26. .参数 A, 字节型
  27. .参数 B, 字节型

  28. 置入代码 ({ 138, 69, 8, 138, 101, 12, 56, 196, 118, 2, 138, 196, 15, 182, 192, 201, 194, 8, 0 })
  29. ' mov al,[ebp+8]
  30. ' mov ah,[ebp+12]
  31. ' .if ah > al
  32. ' mov al,ah
  33. ' .endif
  34. ' movzx eax,al
  35. ' leave
  36. ' retn 8
  37. 返回 (0)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则