设为首页收藏本站帮助中心
查看: 379|回复: 0
收起左侧

易语言实现字节集的 \xHH 编码,可在C语言,C++,PHP 等语言的双引号内使用 (返回文本型)

[复制链接]
发表于 2022-5-28 15:51:01 | 显示全部楼层 |阅读模式
1.png
  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 信息框 (字节集_xHH编码 (到字节集 (“Hello World! 中文测试”)), 0, , )

  9. .子程序 字节集_xHH编码, 文本型, 公开, 编码后可在C语言、C++、PHP等双引号内使用
  10. .参数 数据, 字节集
  11. .局部变量 长度, 整数型
  12. .局部变量 文件号, 整数型
  13. .局部变量 位置, 整数型
  14. .局部变量 字节, 字节型
  15. .局部变量 返回值, 文本型

  16. 长度 = 取字节集长度 (数据)
  17. .如果真 (长度 ≤ 0)
  18.     返回 (“”)
  19. .如果真结束
  20. 文件号 = 打开内存文件 ()
  21. .计次循环首 (长度, 位置)
  22.     字节 = 数据 [位置]
  23.     写出文本 (文件号, “\x” + 字符 (i (右移 (字节, 4))) + 字符 (i (字节)))
  24. .计次循环尾 ()
  25. 移动读写位置 (文件号, #文件首, 0)
  26. 返回值 = 读入文本 (文件号, 取文件长度 (文件号))
  27. 关闭文件 (文件号)
  28. 返回 (返回值)


  29. .子程序 i, 字节型
  30. .参数 i, 字节型, , 输入 0~9 返回:48~57 输入:10~15 返回:65~70 范围:0~15 只取低4位

  31. 置入代码 ({ 138, 69, 8, 36, 15, 60, 9, 119, 4, 4, 48, 235, 2, 4, 55, 15, 182, 192, 201, 194, 4, 0 })
  32. ' mov al,[ebp+8]
  33. ' and al,15
  34. ' .if al <= 9
  35. ' add al,30H
  36. ' .else
  37. ' add al,37H
  38. ' .endif
  39. ' movzx eax,al
  40. ' leave
  41. ' retn 4
  42. 返回 (0)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则