设为首页收藏本站帮助中心
查看: 97|回复: 0
收起左侧

易语言MASM置入代码实现判断32位IEEE754编码小数型数组是否全部运算正确 (返回逻辑型)

[复制链接]
发表于 2022-8-8 18:52:47 | 显示全部楼层 |阅读模式
1.png
  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 数组, 小数型, , "0"

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  9. 数组 = { 1.2, -1.3, 1.4, -1 }
  10. 输出调试文本 (小数型数组_是否运算正确 (数组))
  11. 输出调试文本 (易源码_小数型数组_是否运算正确 (数组))
  12. 数组 = { 1e+100, 3.14, 4.13 }
  13. 输出调试文本 (小数型数组_是否运算正确 (A))
  14. 输出调试文本 (易源码_小数型数组_是否运算正确 (数组))



  15. .子程序 小数型数组_是否运算正确, 逻辑型, 公开, 是否运算正确 () 数组操作 全部正确返回真,有一个出错则返回假 空数组返回假
  16. .参数 欲校验的计算结果数组, 小数型, 数组

  17. 置入代码 ({ 83, 81, 82, 139, 69, 8, 11, 192, 117, 2, 235, 57, 139, 0, 11, 192, 117, 2, 235, 49, 139, 88, 4, 11, 219, 117, 4, 51, 192, 235, 38, 131, 192, 8, 51, 201, 235, 22, 139, 20, 136, 129, 226, 0, 0, 128, 127, 129, 250, 0, 0, 128, 127, 117, 4, 51, 192, 235, 10, 65, 59, 203, 114, 230, 184, 1, 0, 0, 0, 90, 89, 91, 201, 194, 4, 0 })
  18. ' push ebx
  19. ' push ecx
  20. ' push edx
  21. ' mov eax,[ebp+8]
  22. ' .if !eax
  23. ' jmp ASM_END
  24. ' .endif
  25. ' mov eax,[eax]
  26. ' .if !eax
  27. ' jmp ASM_END
  28. ' .endif
  29. ' mov ebx,[eax+4]
  30. ' .if !ebx
  31. ' xor eax,eax
  32. ' jmp ASM_END
  33. ' .endif
  34. ' add eax,8
  35. ' xor ecx,ecx
  36. ' .while ecx < ebx
  37. ' mov edx,[eax+ecx*4]
  38. ' and edx,2139095040
  39. ' .if edx == 2139095040
  40. ' xor eax,eax
  41. ' jmp ASM_END
  42. ' .endif
  43. ' inc ecx
  44. ' .endw
  45. ' mov eax,1
  46. ' ASM_END:
  47. ' pop edx
  48. ' pop ecx
  49. ' pop ebx
  50. ' leave
  51. ' retn 4
  52. 返回 (假)

  53. .子程序 易源码_小数型数组_是否运算正确, 逻辑型
  54. .参数 欲校验的计算结果数组, 小数型, 数组
  55. .局部变量 成员, 整数型
  56. .局部变量 计数, 整数型

  57. 成员 = 取数组成员数 (欲校验的计算结果数组)
  58. .如果真 (成员 = 0)
  59.     返回 (假)
  60. .如果真结束
  61. .计次循环首 (成员, 计数)
  62.     .如果真 (是否运算正确 (欲校验的计算结果数组 [计数]) = 假)
  63.         返回 (假)
  64.     .如果真结束

  65. .计次循环尾 ()
  66. 返回 (真)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则