设为首页收藏本站帮助中心
查看: 571|回复: 0
收起左侧

易语言MASM置入代码判断64位IEEE754编码双精度小数型数组是否运算正确 (返回逻辑型)

[复制链接]
发表于 2022-8-9 16:05:06 | 显示全部楼层 |阅读模式
1.png
  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 数组, 双精度小数型, , "0"

  8. 数组 = { 1.2, -1.3, 1.4, -1 }
  9. 输出调试文本 (双精度小数型数组_是否运算正确 (数组))
  10. 输出调试文本 (易源码_双精度小数型数组_是否运算正确 (数组))
  11. 数组 = { 10000000000, 3.14, 4.13, -1e+019, 1.#INF }
  12. 输出调试文本 (双精度小数型数组_是否运算正确 (数组))
  13. 输出调试文本 (易源码_双精度小数型数组_是否运算正确 (数组))

  14. .子程序 双精度小数型数组_是否运算正确, 逻辑型, , 是否运算正确 () 数组操作 全部正确返回真,有一个出错则返回假 空数组返回假
  15. .参数 欲校验的计算结果数组, 双精度小数型, 数组

  16. 置入代码 ({ 83, 81, 82, 139, 69, 8, 11, 192, 117, 2, 235, 58, 139, 0, 11, 192, 117, 2, 235, 50, 139, 88, 4, 11, 219, 117, 4, 51, 192, 235, 39, 131, 192, 8, 51, 201, 235, 23, 139, 84, 200, 4, 129, 226, 0, 0, 240, 127, 129, 250, 0, 0, 240, 127, 117, 4, 51, 192, 235, 10, 65, 59, 203, 114, 229, 184, 1, 0, 0, 0, 90, 89, 91, 201, 194, 4, 0 })
  17. ' push ebx
  18. ' push ecx
  19. ' push edx
  20. ' mov eax,[ebp+8]
  21. ' .if !eax
  22. ' jmp ASM_END
  23. ' .endif
  24. ' mov eax,[eax]
  25. ' .if !eax
  26. ' jmp ASM_END
  27. ' .endif
  28. ' mov ebx,[eax+4]
  29. ' .if !ebx
  30. ' xor eax,eax
  31. ' jmp ASM_END
  32. ' .endif
  33. ' add eax,8
  34. ' xor ecx,ecx
  35. ' .while ecx < ebx
  36. ' mov edx,[eax+ecx*8+4]
  37. ' and edx,2146435072
  38. ' .if edx == 2146435072
  39. ' xor eax,eax
  40. ' jmp ASM_END
  41. ' .endif
  42. ' inc ecx
  43. ' .endw
  44. ' mov eax,1
  45. ' ASM_END:
  46. ' pop edx
  47. ' pop ecx
  48. ' pop ebx
  49. ' leave
  50. ' retn 4
  51. 返回 (假)

  52. .子程序 易源码_双精度小数型数组_是否运算正确, 逻辑型
  53. .参数 欲校验的计算结果数组, 双精度小数型, 数组
  54. .局部变量 成员, 整数型
  55. .局部变量 计数, 整数型

  56. 成员 = 取数组成员数 (欲校验的计算结果数组)
  57. .如果真 (成员 = 0)
  58.     返回 (假)
  59. .如果真结束
  60. .计次循环首 (成员, 计数)
  61.     .如果真 (是否运算正确 (欲校验的计算结果数组 [计数]) = 假)
  62.         返回 (假)
  63.     .如果真结束

  64. .计次循环尾 ()
  65. 返回 (真)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则