设为首页收藏本站帮助中心
查看: 261|回复: 0
收起左侧

易语言 利用《农历日期支持库》实现获取所有年份的中秋节与教师节等于9月10日的可能

[复制链接]
发表于 2022-9-10 09:52:41 | 显示全部楼层 |阅读模式
1.png
  1. .版本 2
  2. .支持库 CnCalendar

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 日期, 日期时间型
  9. .局部变量 年, 整数型
  10. .局部变量 文本, 文本型

  11. .计次循环首 (9999, 年)
  12.     .如果真 (农历转公历 (年, 8, 15, 假, 日期))
  13.         .如果真 (取月份 (日期) = 9 且 取日 (日期) = 10)
  14.             文本 = 文本 + 到文本 (日期) + #换行符
  15.         .如果真结束

  16.     .如果真结束

  17. .计次循环尾 ()
  18. 信息框 (文本, 0, , )

复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则