设为首页收藏本站帮助中心
查看: 165|回复: 0
收起左侧

易语言MASM置入代码判断校验日期时间型变量数据是否正确 (是否运算正确) (返回逻辑型)

[复制链接]
发表于 2022-11-27 18:22:54 | 显示全部楼层 |阅读模式
1.png
  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 时间, 日期时间型
  8. .局部变量 时间B, 日期时间型

  9. 时间 = 取现行时间 ()
  10. 输出调试文本 (日期时间型_数据是否正确 (时间))
  11. 输出调试文本 (日期时间型_数据是否正确 ([100年12月31日]))
  12. 时间B = 长整数型_到日期时间型 (-1)
  13. 输出调试文本 (时间B)
  14. 输出调试文本 (日期时间型_数据是否正确 (时间B))


  15. .子程序 日期时间型_数据是否正确, 逻辑型, 公开, 校验一个 日期时间型 变量的数据是否合法有效。
  16. .参数 欲校验的计算结果, 日期时间型, , 如果该日期时间型 数据正确有效,返回真,如果是运算错误或溢出后的结果,返回假

  17. 置入代码 ({ 139, 69, 12, 37, 0, 0, 240, 127, 61, 0, 0, 240, 127, 117, 4, 51, 192, 235, 5, 184, 1, 0, 0, 0, 201, 194, 8, 0 })
  18. ' mov eax,[ebp+12]
  19. ' and eax,2146435072
  20. ' .if eax == 2146435072
  21. ' xor eax,eax
  22. ' .else
  23. ' mov eax,1
  24. ' .endif
  25. ' leave
  26. ' retn 8
  27. 返回 (假)


  28. .子程序 长整数型_到日期时间型, 日期时间型, 公开
  29. .参数 长整数, 长整数型

  30. 置入代码 ({ 139, 69, 8, 139, 85, 12, 201, 194, 8, 0 })
  31. ' mov eax,[ebp+8]
  32. ' mov edx,[ebp+12]
  33. ' leave
  34. ' retn 8
  35. 返回 ([100年1月1日])
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则