设为首页收藏本站帮助中心
查看: 334|回复: 0
收起左侧

易语言MASM置入代码实现子程序指针的循环左移 与 循环右移 0~31位 (返回子程序指针)

[复制链接]
发表于 2023-2-5 18:40:39 | 显示全部楼层 |阅读模式
1.png
  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1, , ,

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 A, 子程序指针
  9. .局部变量 B, 子程序指针
  10. .局部变量 计数, 整数型

  11. A = &子程序指针_循环左移
  12. B = &子程序指针_循环右移
  13. .计次循环首 (64, 计数)
  14.     A = 子程序指针_循环左移 (A, 1)
  15.     B = 子程序指针_循环右移 (B, 1)
  16.     调试输出 (计数, A, B)
  17. .计次循环尾 ()

  18. .子程序 子程序指针_循环左移, 子程序指针, 公开
  19. .参数 欲移动的指针, 子程序指针
  20. .参数 欲移动的位数, 字节型

  21. 置入代码 ({ 81, 139, 69, 8, 138, 77, 12, 211, 192, 89, 201, 194, 8, 0 })
  22. ' push ecx
  23. ' mov eax,[ebp+8]
  24. ' mov cl,[ebp+12]
  25. ' rol eax,cl
  26. ' pop ecx
  27. ' leave
  28. ' retn 8
  29. 返回 (&子程序指针_循环左移)

  30. .子程序 子程序指针_循环右移, 子程序指针, 公开
  31. .参数 欲移动的指针, 子程序指针
  32. .参数 欲移动的位数, 字节型

  33. 置入代码 ({ 81, 139, 69, 8, 138, 77, 12, 211, 200, 89, 201, 194, 8, 0 })
  34. ' push ecx
  35. ' mov eax,[ebp+8]
  36. ' mov cl,[ebp+12]
  37. ' ror eax,cl
  38. ' pop ecx
  39. ' leave
  40. ' retn 8
  41. 返回 (&子程序指针_循环右移)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则