设为首页收藏本站帮助中心
查看: 308|回复: 0
收起左侧

易语言MASM置入代码实现将32位整数型数值拆分成两个16位短整数型变量传出 (无返回值)

[复制链接]
发表于 2023-2-20 15:33:58 | 显示全部楼层 |阅读模式
1.png
  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 高16位, 短整数型
  8. .局部变量 低16位, 短整数型
  9. .局部变量 计数, 整数型

  10. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  11. .变量循环首 (-100000000, 100000000, 1, 计数)
  12.     拆分整数 (计数, 低16位, 高16位)
  13.     .如果真 (合并整数 (低16位, 高16位) ≠ 计数)
  14.         暂停 ()
  15.     .如果真结束

  16. .变量循环尾 ()


  17. .子程序 拆分整数, , 公开, 将整数型拆分成两个短整数型,可使用核心库的 合并整数() 还原
  18. .参数 整数, 整数型
  19. .参数 低16位, 短整数型, 参考, 变量传出结果,必须是变量,不能是函数返回值或常量,否则会出错
  20. .参数 高16位, 短整数型, 参考

  21. 置入代码 ({ 80, 83, 139, 69, 8, 139, 93, 12, 102, 137, 3, 193, 200, 16, 139, 93, 16, 102, 137, 3, 91, 88 })
  22. ' push eax
  23. ' push ebx
  24. ' mov eax,[ebp+8]
  25. ' mov ebx,[ebp+12]
  26. ' mov [ebx],ax
  27. ' ror eax,16
  28. ' mov ebx,[ebp+16]
  29. ' mov [ebx],ax
  30. ' pop ebx
  31. ' pop eax
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则