设为首页收藏本站帮助中心
查看: 177|回复: 0
收起左侧

易语言MASM置入代码返回一个与字节集变量数据地址相同的联合体文本字符串(返回文本型)

[复制链接]
发表于 2023-8-4 11:31:19 | 显示全部楼层 |阅读模式
1.png
  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 字节集, 字节集
  9. .局部变量 文本, 文本型
  10. .局部变量 时间, 整数型

  11. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  12. 字节集 = 到字节集 (“Hello World! 中文测试”) + { 0 }
  13. 文本 = 字节集_联合到文本 (字节集)
  14. 调试输出 (取文本长度 (文本), 取文本长度 (到文本 (字节集)))
  15. 调试输出 (到文本 (字节集), 文本)
  16. 字节集 [1] = 77  ' 第1字节修改为字母:M
  17. 检查 (取变量数据地址 (字节集) = 取变量数据地址 (文本))
  18. 调试输出 (到文本 (字节集), 文本)


  19. .子程序 字节集_联合到文本, 文本型, 公开, 返回一个文本型,变量数据地址与字节集相同
  20. .参数 字节集, 字节集, , 必须是变量,末尾必须加:字符0,否则末尾会出乱码导致程序异常

  21. 置入代码 ({ 139, 69, 8, 139, 0, 131, 192, 8, 201, 194, 4, 0 })
  22. ' mov eax,[ebp+8]
  23. ' mov eax,[eax]
  24. ' add eax,8
  25. ' leave
  26. ' retn 4

  27. 返回 (“”)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则