免费邀请码更改用户名CRC32解密2.0回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 314|回复: 3
收起左侧

易语言 按长度分割字节集的实现方法 相当于php的 str_split() 函数。

[复制链接]
发表于 2017-9-7 13:14:11 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
  1. .版本 2
  2. .支持库 spec

  3. .程序集 窗口程序集_启动窗口

  4. .子程序 __启动窗口_创建完毕
  5. .局部变量 结果, 字节集, , "0"

  6. 按长度分割字节集 ({ 1, 2, 3, 4, 5, 6, 7, 8, 9, 11, 13 }, 2, 结果)
  7. 调试输出 (结果)
  8. 结束 ()

  9. .子程序 按长度分割字节集, , 公开
  10. .参数 字节集数据, 字节集
  11. .参数 分割长度, 整数型
  12. .参数 字节集数组, 字节集, 参考 数组
  13. .局部变量 分割数量, 整数型
  14. .局部变量 分割计数, 整数型
  15. .局部变量 长度计数, 整数型
  16. .局部变量 分割数据, 字节集
  17. .局部变量 总计数, 整数型

  18. 分割数量 = 取字节集长度 (字节集数据) ÷ 分割长度
  19. .如果真 (取字节集长度 (字节集数据) ÷ 分割长度 ≠ 到整数 (取字节集长度 (字节集数据) ÷ 分割长度))
  20.     分割数量 = 分割数量 + 1
  21. .如果真结束
  22. 重定义数组 (字节集数组, 假, 分割数量)

  23. .计次循环首 (分割数量, 分割计数)
  24.     分割数据 = {  }
  25.     .计次循环首 (分割长度, 长度计数)
  26.         总计数 = 总计数 + 1
  27.         .如果真 (总计数 > 取字节集长度 (字节集数据))
  28.             跳出循环 ()
  29.         .如果真结束
  30.         分割数据 = 分割数据 + 到字节集 (字节集数据 [总计数])
  31.     .计次循环尾 ()
  32.     字节集数组 [分割计数] = 分割数据
  33. .计次循环尾 ()
复制代码



相关帖子

回复

使用道具 举报

腾讯云国际顶级CA机构SSL证书8.8折,云解析买一年最高送半年。
发表于 2017-9-7 23:00:33 | 显示全部楼层
本帖最后由 吃瓜群众 于 2017-9-7 23:07 编辑

核心库里该有的没有,以后都要有。

回复 支持 反对

使用道具 举报

发表于 2017-9-22 16:45:59 来自手机 | 显示全部楼层
吃瓜群众 发表于 2017-9-7 23:00
核心库里该有的没有,以后都要有。

楼上发明个支持库封装这玩意。
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-7-17 22:18, 54.198.246.164 , Processed in 1.918849 second(s), 30 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表