设为首页收藏本站帮助中心
查看: 2293|回复: 25
收起左侧

教你用易语言做个世界上最简单的浏览器

[复制链接]
回帖奖励 12 枚从币 回复本帖可获得 3 枚从币奖励! 每人限 1 次(中奖概率 80%)
发表于 2017-9-21 10:15:33 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
  • 准备一个易语言程序,百度上有汉化破解版的:
1.png
  • 打开易语言,新建一个空白程序,如下图所示:
2.png
  • 然后就出现了易语言窗口设计界面:
3.png
  • 然后看看有没有扩展组件:
4.png
  • 若没有就自己弄上去,步骤如下:
5.png
6.png
  • 然后寻找一个叫超文本浏览框的窗口组件,
若找不到,就只能到百度找支持库了:
7.png
  • 将其超文本浏览框放置在窗口内:
8.png
  • 然后放置一个编辑框和按钮,并将按钮标题改为浏览:
9.png
  • 然后双击启动窗口,插入以下代码:

  1. .版本 2
  2. .支持库 HtmlView
  3. .程序集 窗口程序集_启动窗口
  4. .子程序 _按钮1_被单击
  5. 超文本浏览框1.地址 = 编辑框1.内容
复制代码

11.png
  • 点击运行,输入本站网址,即可浏览,如下图所示:
10.png

不会做的盆友们可以下载这个:
浏览器.rar (587.69 KB, 下载次数: 23)

评分

参与人数 2从币 +2 +1 收起 理由
Kuni7wa + 1 我只是路过顶个帖子而已
Cute + 1 + 1 赞一个!

查看全部评分

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

发表于 2017-9-30 17:28:29 | 显示全部楼层
不想长大 发表于 2017-9-27 20:14
浏览功能还是靠ie实现,

这相当于调用ie浏览器控件实现的浏览功能,根本算不上是什么独立浏览器。

这个小可爱很神秘,什么都没留下
回复 支持 反对

使用道具 举报

发表于 2017-9-24 08:08:47 | 显示全部楼层
糯米果子 发表于 2017-9-23 19:19
应该吧,只要图多应该都能加精的呢。

表示都有3个月,过期了是什么情况没人清楚。

这个小可爱很神秘,什么都没留下
回复 支持 反对

使用道具 举报

发表于 2017-9-24 10:11:59 | 显示全部楼层
520 发表于 2017-9-24 08:08
表示都有3个月,过期了是什么情况没人清楚。

这个只有等过期了再看吧。

这个小可爱很神秘,什么都没留下
回复 支持 反对

使用道具 举报

发表于 2017-9-21 14:33:38 | 显示全部楼层

回帖奖励 +3 枚从币

呵呵,这个不错,我也去试试。
这个小可爱很神秘,什么都没留下
回复 支持 反对

使用道具 举报

发表于 2017-9-21 21:17:37 | 显示全部楼层

回帖奖励 +3 枚从币

这个不错,666
这个小可爱很神秘,什么都没留下
回复 支持 反对

使用道具 举报

发表于 2017-9-21 22:33:33 | 显示全部楼层

回帖奖励 +3 枚从币

这个方法不错。
这个小可爱很神秘,什么都没留下
回复 支持 反对

使用道具 举报

发表于 2017-9-22 17:30:32 来自手机 | 显示全部楼层
demon 发表于 2017-9-22 17:28
....无语。

表示就发个这也有精华。
这个小可爱很神秘,什么都没留下
回复 支持 反对

使用道具 举报

发表于 2017-9-23 19:19:42 | 显示全部楼层
Kuni7wa 发表于 2017-9-22 17:30
表示就发个这也有精华。

应该吧,只要图多应该都能加精的呢。

这个小可爱很神秘,什么都没留下
回复 支持 反对

使用道具 举报

发表于 2017-9-27 20:14:23 | 显示全部楼层

回帖奖励 +3 枚从币

浏览功能还是靠ie实现,{:12_3079:}
这个小可爱很神秘,什么都没留下
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则