设为首页收藏本站帮助中心
查看: 619|回复: 1
收起左侧

易语言实现检测一个整数是否为回文数以及生成的算法

[复制链接]
发表于 2017-10-19 23:29:34 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 数, 整数型

  9. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  10. .计次循环首 (1000000, 数)
  11.     .如果真 (是否为回文数 (数))
  12.         调试输出 (数)
  13.     .如果真结束

  14. .计次循环尾 ()

  15. .子程序 是否为回文数, 逻辑型, 公开
  16. .参数 数, 整数型

  17. 返回 (到字节集 (到文本 (数)) = 字节集倒序 (到字节集 (到文本 (数))))


  18. .子程序 字节集倒序, 字节集, 公开
  19. .参数 数据, 字节集
  20. .局部变量 长度, 整数型
  21. .局部变量 计数, 整数型
  22. .局部变量 返回值, 字节集
  23. .局部变量 倒计数, 整数型

  24. 长度 = 取字节集长度 (数据)
  25. 返回值 = 取空白字节集 (长度)
  26. 倒计数 = 长度
  27. .计次循环首 (长度, 计数)
  28.     返回值 [计数] = 数据 [倒计数]
  29.     倒计数 = 倒计数 - 1
  30. .计次循环尾 ()
  31. 返回 (返回值)


复制代码



相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

发表于 2018-2-7 21:52:47 | 显示全部楼层
那个一百万记次循环呃...
这个小可爱很神秘,什么都没留下
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则