设为首页收藏本站CRC32解密2.0更改用户名回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
搜索
查看: 82|回复: 2
收起左侧

易语言实现删除引号内所有文本字符串的实现方法(引号外的不会被删除,支持单双引号)

[复制链接]
发表于 2018-11-28 09:47:19 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。

  8. 输出调试文本 (删引号内文本 (“'123' Hello World! '会被删除'不会被删除'单引号内的文本都会被删除'单引号外的文本不会被删除 'Hello World'” + #引号 + “双引号内的文本也不会被删除” + #引号 + “'456'”, 真))

  9. .子程序 删引号内文本, 文本型, 公开, 删除引号内所有的文本(支持单双引号)
  10. .参数 文本, 文本型, , 不支持转义符,必须对称使用否则会出错
  11. .参数 单双引号, 逻辑型, 可空, 真为单引号,假为双引号
  12. .局部变量 字节集, 字节集
  13. .局部变量 字节数组, 字节型, , "0"
  14. .局部变量 字节, 字节型
  15. .局部变量 长度, 整数型
  16. .局部变量 计数, 整数型
  17. .局部变量 引号内, 逻辑型
  18. .局部变量 引号字节, 字节型
  19. .局部变量 删除长度, 整数型
  20. .局部变量 删除起始位置, 整数型
  21. .局部变量 添加空格, 逻辑型
  22. .局部变量 删除位置表, 整数型, , "0"
  23. .局部变量 删除长度表, 整数型, , "0"

  24. 引号字节 = 选择 (单双引号, 39, 34)
  25. 引号内 = 假
  26. 字节集 = 到字节集 (文本)
  27. 字节集交换字节型数组 (字节集, 字节数组)
  28. .如果真 (取文本右边 (文本, 1) = 字符 (引号字节))
  29.     加入成员 (字节数组, 32)
  30.     添加空格 = 真
  31. .如果真结束
  32. 长度 = 取数组成员数 (字节数组)
  33. .计次循环首 (长度, 计数)
  34.     字节 = 字节数组 [计数]
  35.     .如果真 (字节 = 引号字节)
  36.         引号内 = 取反 (引号内)
  37.     .如果真结束
  38.     .如果 (引号内 或 字节 = 引号字节)
  39.         .如果真 (删除起始位置 = 0)
  40.             删除起始位置 = 计数
  41.         .如果真结束
  42.         删除长度 = 删除长度 + 1
  43.     .否则
  44.         .如果真 (删除长度 ≠ 0)
  45.             加入成员 (删除位置表, 删除起始位置)
  46.             加入成员 (删除长度表, 删除长度)
  47.         .如果真结束
  48.         删除长度 = 0
  49.         删除起始位置 = 0
  50.     .如果结束

  51. .计次循环尾 ()
  52. .变量循环首 (取数组成员数 (删除位置表), 1, -1, 计数)
  53.     删除成员 (字节数组, 删除位置表 [计数], 删除长度表 [计数])
  54. .变量循环尾 ()
  55. .如果真 (添加空格)
  56.     删除成员 (字节数组, 取数组成员数 (字节数组), 1)
  57. .如果真结束
  58. 返回 (到文本 (字节数组))

  59. .子程序 字节集交换字节型数组
  60. .参数 字节集, 字节集
  61. .参数 字节数组, 字节型, 数组

  62. 置入代码 ({ 96, 139, 69, 8, 139, 93, 12, 139, 8, 139, 19, 137, 16, 137, 11, 97 })

复制代码

回复

使用道具 举报

腾讯云新春采购节 热门云产品3折起,爆款超值秒杀,新购高额满返,升级享优惠大礼包!
发表于 2018-11-28 10:48:56 | 显示全部楼层
6666
回复 支持 反对

使用道具 举报

发表于 2018-12-23 10:49:54 | 显示全部楼层
唔,路过帮顶
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

小黑屋|手机版|Archiver|官方QQ群|从F到0 ( 蒙ICP备17002595号-1 )
蒙公网安备 15010402000325号 腾讯云安全认证

GMT+8, 2019-5-20 17:45, 3.80.223.123 , Processed in 0.110351 second(s), 31 queries .

Powered by Discuz! X3.4 © 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表