设为首页收藏本站帮助中心
查看: 138|回复: 0
收起左侧

易语言MASM置入代码将短整数型(-32768~32767)转换到无符号整数型(0~65535,返回整数型)

[复制链接]
发表于 2022-4-16 15:10:37 | 显示全部楼层 |阅读模式

孩子辍学不想上学打工咋办?
来我这免费学:易语言、51单片机、FPGA(IC设计)、PHP Dsicuz! 程序修改、MASM汇编,包教包会,学废为止。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png
  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 i, 短整数型

  9. i = 12345
  10. 调试输出 (i, 短整数型_到无符号整数型 (i))
  11. i = -1
  12. 调试输出 (i, 短整数型_到无符号整数型 (i))
  13. i = -12345
  14. 调试输出 (i, 短整数型_到无符号整数型 (i))
  15. i = 0
  16. 调试输出 (i, 短整数型_到无符号整数型 (i))

  17. .子程序 短整数型_到无符号整数型, 整数型, 公开, 返回:0~65535
  18. .参数 待转换的数值, 短整数型, , 范围:-32768~32767

  19. 置入代码 ({ 102, 139, 69, 8, 15, 183, 192, 201, 194, 4, 0 })
  20. ' mov ax,[ebp+8]
  21. ' movzx eax,ax
  22. ' leave
  23. ' retn 4
  24. 返回 (0)
复制代码

相关帖子

本站源码使用前请注意检查,如有问题请点击右下角举报,将在24小时内得到答复。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则