设为首页收藏本站帮助中心
查看: 113|回复: 0
收起左侧

易语言MASM置入代码实现将GBK编码值:1~65535 还原为汉字、符号 (返回文本型:1~2字节)

[复制链接]
发表于 2023-10-1 19:25:23 | 显示全部楼层 |阅读模式
1.png
  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. 输出调试文本 (GBK编码到汉字 (53975))
  8. 输出调试文本 (GBK编码到汉字 (54255))
  9. 输出调试文本 (GBK编码到汉字 (53716))

  10. .子程序 GBK编码到汉字, 文本型, 公开, 将GBK编码值还原为文本:1~2字节 (输入0返回0字节空文本)
  11. .参数 编码, 整数型, , 范围:1~65535 输入:53975(0xD2D7) 返回:易
  12. .局部变量 返回值, 文本型

  13. 返回值 = 取空白文本 (2)
  14. 置入代码 ({ 83, 102, 139, 69, 8, 10, 228, 116, 4, 102, 193, 200, 8, 139, 93, 252, 102, 137, 3, 91 })
  15. ' push ebx
  16. ' mov ax,[ebp+8]
  17. ' .if ah
  18. ' ror ax,8
  19. ' .endif
  20. ' mov ebx,[ebp-4]
  21. ' mov [ebx],ax
  22. ' pop ebx
  23. 返回 (返回值)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则