设为首页收藏本站帮助中心
查看: 99|回复: 0
收起左侧

易语言MASM置入代码判断文本型字符串是否包含双字节字符(汉字,全角符号等,返回逻辑型)

[复制链接]
发表于 2023-9-20 11:03:26 | 显示全部楼层 |阅读模式
1.png
  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. 输出调试文本 (文本型_是否包含双字节字符 (“Hello World!”))
  8. 输出调试文本 (文本型_是否包含双字节字符 (“Hello World! 中文测试”))


  9. .子程序 文本型_是否包含双字节字符, 逻辑型, 公开, 找到双字节字符(汉字,全角特殊符号等)返回真,否则返回假
  10. .参数 文本数据, 文本型

  11. 置入代码 ({ 83, 139, 69, 8, 131, 248, 0, 127, 4, 51, 192, 235, 43, 139, 0, 131, 248, 0, 127, 4, 51, 192, 235, 32, 138, 24, 10, 219, 117, 6, 51, 192, 235, 22, 235, 17, 128, 251, 128, 118, 12, 128, 251, 255, 116, 7, 184, 1, 0, 0, 0, 235, 3, 64, 235, 224, 91, 201, 194, 4, 0 })
  12. ' push ebx
  13. ' mov eax,[ebp+8]
  14. ' .if sdword ptr eax <= 0
  15. ' xor eax,eax
  16. ' jmp ASM_END
  17. ' .endif
  18. ' mov eax,[eax]
  19. ' .if sdword ptr eax <= 0
  20. ' xor eax,eax
  21. ' jmp ASM_END
  22. ' .endif
  23. ' .while 1
  24. ' mov bl,[eax]
  25. ' .if !bl
  26. ' xor eax,eax
  27. ' .break
  28. ' .elseif bl > 128 && bl != 255
  29. ' mov eax,1
  30. ' .break
  31. ' .endif
  32. ' inc eax
  33. ' .endw
  34. ' ASM_END:
  35. ' pop ebx
  36. ' leave
  37. ' retn 4
  38. 返回 (假)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则