设为首页收藏本站帮助中心
查看: 132|回复: 0
收起左侧

易语言MASM置入代码 判断IPv4格式地址是否属于广域网外网 或局域网内网私网保留无效IP

[复制链接]
发表于 2023-9-2 21:26:39 | 显示全部楼层 |阅读模式
1.png
  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。

  8. 输出调试文本 (是否为公网IPv4地址 (反转整数字节序 (取字节集数据 ({ 127, 0, 0, 1 }, #整数型, ))))
  9. 输出调试文本 (是否为公网IPv4地址 (反转整数字节序 (取字节集数据 ({ 169, 254, 1, 2 }, #整数型, ))))
  10. 输出调试文本 (是否为公网IPv4地址 (反转整数字节序 (取字节集数据 ({ 172, 16, 9, 9 }, #整数型, ))))
  11. 输出调试文本 (是否为公网IPv4地址 (反转整数字节序 (取字节集数据 ({ 172, 26, 32, 64 }, #整数型, ))))
  12. 输出调试文本 (是否为公网IPv4地址 (反转整数字节序 (取字节集数据 ({ 123, 123, 123, 123 }, #整数型, ))))


  13. .子程序 是否为公网IPv4地址, 逻辑型, 公开, 广域网,公网,外网IP返回真,局域网,私网,内网,保留,无效IP返回假
  14. .参数 数字IPv4地址, 整数型, , 格式:地址:127.0.0.1 十六进制:0x7F000001 十进制:2130706433

  15. ' 以下范围IP返回假,其余返回真:
  16. ' 0.0.0.0 ~ 0.255.255.255
  17. ' 10.0.0.0 ~ 10.255.255.255
  18. ' 127.0.0.0 ~ 127.255.255.255
  19. ' 169.254.0.0 ~ 169.254.255.255
  20. ' 192.168.0.0 ~ 192.168.255.255
  21. ' 172.16.0.0 ~ 172.31.255.255
  22. ' 224.0.0.0 ~ 255.255.255.255
  23. 置入代码 ({ 83, 81, 139, 69, 8, 139, 216, 139, 200, 129, 227, 0, 0, 0, 255, 129, 225, 0, 0, 255, 255, 11, 219, 116, 32, 129, 251, 0, 0, 0, 10, 116, 24, 129, 251, 0, 0, 0, 127, 116, 16, 129, 249, 0, 0, 254, 169, 116, 8, 129, 249, 0, 0, 168, 192, 117, 4, 51, 192, 235, 34, 61, 0, 0, 16, 172, 114, 11, 61, 255, 255, 32, 172, 119, 4, 51, 192, 235, 16, 61, 0, 0, 0, 224, 114, 4, 51, 192, 235, 5, 184, 1, 0, 0, 0, 81, 83, 201, 194, 4, 0 })
  24. ' push ebx
  25. ' push ecx
  26. ' mov eax,[ebp+8]
  27. ' mov ebx,eax
  28. ' mov ecx,eax
  29. ' and ebx,0FF000000H
  30. ' and ecx,0FFFF0000H
  31. ' ;0.*.*.*,10.*.*.*,127.*.*.*,169.254.*.*,192.168.*.*
  32. ' .if ebx == 0  || ebx == 00A000000H || ebx == 07F000000H || ecx == 0A9FE0000H || ecx == 0C0A80000H
  33. ' xor eax,eax
  34. ' jmp ASM_END
  35. ' .endif
  36. ' ;172.16.0.0~172.31.255.255
  37. ' .if eax >= 0AC100000H && eax <= 0AC20FFFFH
  38. ' xor eax,eax
  39. ' jmp ASM_END
  40. ' .endif
  41. ' ;224.0.0.0~255.255.255.255
  42. ' .if eax >= 0E0000000H
  43. ' xor eax,eax
  44. ' jmp ASM_END
  45. ' .endif
  46. ' mov eax,1
  47. ' ASM_END:
  48. ' push ecx
  49. ' push ebx
  50. ' leave
  51. ' retn 4
  52. 返回 (假)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则