设为首页收藏本站帮助中心
查看: 126|回复: 0
收起左侧

易语言MASM置入代码实现将文本型变量快速清空 清除为0字节 零字节空白文本 (无返回值)

[复制链接]
发表于 2023-10-6 08:49:19 | 显示全部楼层 |阅读模式
1.png
  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 变量, 文本型
  9. .局部变量 时间, 整数型
  10. .局部变量 文本, 文本型

  11. 变量 = 取空白文本 (500000000)
  12. 时间 = 取启动时间 ()
  13. 文本型_清空 (变量)
  14. 文本 = “置入代码耗时(ms):” + 到文本 (取启动时间 () - 时间) + #换行符

  15. 变量 = 取空白文本 (5000000000)
  16. 时间 = 取启动时间 ()
  17. 变量 = “”
  18. 文本 = 文本 + “易语言耗时(ms):” + 到文本 (取启动时间 () - 时间)
  19. 调试输出 (变量)
  20. 信息框 (文本, 0, , )


  21. .子程序 文本型_清空, , 公开, 将文本型变量快速清空为0字节空白文本
  22. .参数 文本型变量, 文本型, 参考, 必须是文本型变量

  23. 置入代码 ({ 80, 83, 139, 69, 8, 131, 248, 0, 127, 2, 235, 13, 139, 0, 131, 248, 0, 127, 2, 235, 4, 179, 0, 136, 24, 91, 88 })
  24. ' push eax
  25. ' push ebx
  26. ' mov eax,[ebp+8]
  27. ' .if sdword ptr eax <= 0
  28. ' jmp ASM_END
  29. ' .endif
  30. ' mov eax,[eax]
  31. ' .if sdword ptr eax <= 0
  32. ' jmp ASM_END
  33. ' .endif
  34. ' mov bl,0
  35. ' mov [eax],bl
  36. ' ASM_END:
  37. ' pop ebx
  38. ' pop eax

复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则