免扫码快速登录设为首页收藏本站帮助中心
查看: 87|回复: 0
收起左侧

易语言MASM置入代码实现字节型、字节集数据交换高低4位半字节(可操作数组、无返回值)

[复制链接]
发表于 2019-10-6 16:00:00 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 字节集, 字节集
  9. .局部变量 字节型数组, 字节型, , "0"
  10. .局部变量 字节集数组, 字节集, , "5"

  11. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  12. 字节集 = { 1, 2, 3, 4, 5 }
  13. 字节集_半字节交换 (字节集)
  14. 调试输出 (字节集)
  15. 字节型数组 = { 123, 234, 100, 200, 255 }
  16. 字节型数组_半字节交换 (字节型数组)
  17. 调试输出 (字节型数组)
  18. 字节集数组 [1] = { 1, 2, 3, 4, 5 }
  19. 字节集数组 [2] = { 2, 3, 4, 5, 6 }
  20. 字节集数组 [3] = { 10, 20, 30, 40, 50 }
  21. 字节集数组 [4] = { 12, 23, 34, 45, 56 }
  22. 字节集数组 [5] = { 11, 22, 33, 44, 55 }
  23. 字节集数组_半字节交换 (字节集数组)
  24. 调试输出 (字节集数组)
  25. 字节集数组_半字节交换 (字节集数组)
  26. 调试输出 (字节集数组)
  27. 调试输出 (字节型_半字节交换 (123))

  28. .子程序 字节集_半字节交换, , 公开
  29. .参数 字节集, 字节集

  30. 置入代码 ({ 80, 83, 81, 82, 139, 69, 8, 11, 192, 117, 2, 235, 38, 139, 0, 11, 192, 117, 2, 235, 30, 139, 88, 4, 11, 219, 117, 2, 235, 21, 131, 192, 8, 51, 201, 235, 10, 138, 20, 1, 192, 202, 4, 136, 20, 1, 65, 59, 203, 114, 242, 90, 89, 91, 88 })
  31. ' push eax
  32. ' push ebx
  33. ' push ecx
  34. ' push edx
  35. ' mov eax,[ebp+8]
  36. ' .if eax == 0
  37. ' jmp ASM_END
  38. ' .endif
  39. ' mov eax,[eax]
  40. ' .if eax == 0
  41. ' jmp ASM_END
  42. ' .endif
  43. ' mov ebx,[eax+4]
  44. ' .if ebx == 0
  45. ' jmp ASM_END
  46. ' .endif
  47. ' add eax,8
  48. ' xor ecx,ecx
  49. ' .while ecx < ebx
  50. ' mov dl,[eax+ecx]
  51. ' ror dl,4
  52. ' mov [eax+ecx],dl
  53. ' inc ecx
  54. ' .endw
  55. ' ASM_END:
  56. ' pop edx
  57. ' pop ecx
  58. ' pop ebx
  59. ' pop eax


  60. .子程序 字节型数组_半字节交换, , 公开
  61. .参数 字节型数组, 字节型, 数组

  62. 置入代码 ({ 80, 83, 81, 82, 139, 69, 8, 11, 192, 117, 2, 235, 38, 139, 0, 11, 192, 117, 2, 235, 30, 139, 88, 4, 11, 219, 117, 2, 235, 21, 131, 192, 8, 51, 201, 235, 10, 138, 20, 1, 192, 202, 4, 136, 20, 1, 65, 59, 203, 114, 242, 90, 89, 91, 88 })
  63. ' push eax
  64. ' push ebx
  65. ' push ecx
  66. ' push edx
  67. ' mov eax,[ebp+8]
  68. ' .if eax == 0
  69. ' jmp ASM_END
  70. ' .endif
  71. ' mov eax,[eax]
  72. ' .if eax == 0
  73. ' jmp ASM_END
  74. ' .endif
  75. ' mov ebx,[eax+4]
  76. ' .if ebx == 0
  77. ' jmp ASM_END
  78. ' .endif
  79. ' add eax,8
  80. ' xor ecx,ecx
  81. ' .while ecx < ebx
  82. ' mov dl,[eax+ecx]
  83. ' ror dl,4
  84. ' mov [eax+ecx],dl
  85. ' inc ecx
  86. ' .endw
  87. ' ASM_END:
  88. ' pop edx
  89. ' pop ecx
  90. ' pop ebx
  91. ' pop eax


  92. .子程序 字节集数组_半字节交换, , 公开
  93. .参数 字节集数组, 字节集, 数组

  94. 置入代码 ({ 96, 139, 85, 8, 11, 210, 117, 2, 235, 70, 139, 18, 11, 210, 117, 2, 235, 62, 139, 90, 4, 11, 219, 116, 8, 129, 251, 0, 0, 0, 128, 114, 2, 235, 45, 131, 194, 8, 51, 201, 235, 34, 139, 4, 138, 11, 192, 116, 26, 96, 139, 88, 4, 131, 192, 8, 51, 201, 235, 10, 138, 20, 1, 192, 202, 4, 136, 20, 1, 65, 59, 203, 114, 242, 97, 65, 59, 203, 114, 218, 97 })
  95. ' pushad
  96. ' mov edx,[ebp+8]
  97. ' .if !edx
  98. ' jmp  ASM_END
  99. ' .endif
  100. ' mov edx,[edx]
  101. ' .if !edx
  102. ' jmp  ASM_END
  103. ' .endif
  104. ' mov ebx,[edx+4]
  105. ' .if !ebx || ebx >= 80000000H
  106. ' jmp  ASM_END
  107. ' .endif
  108. ' add edx,8
  109. ' xor ecx,ecx
  110. ' .while ecx < ebx
  111. ' mov eax,[edx+ecx*4]
  112. ' .if eax
  113. ' pushad
  114. ' mov ebx,[eax+4]
  115. ' add eax,8
  116. ' xor ecx,ecx
  117. ' .while ecx < ebx
  118. ' mov dl,[eax+ecx]
  119. ' ror dl,4
  120. ' mov [eax+ecx],dl
  121. ' inc ecx
  122. ' .endw
  123. ' popad
  124. ' .endif
  125. ' inc ecx
  126. ' .endw
  127. ' ASM_END:
  128. ' popad


  129. .子程序 字节型_半字节交换, 字节型, 公开, 交换字节高低4位(半字节)
  130. .参数 字节型, 字节型, , SWAP A

  131. 置入代码 ({ 138, 69, 8, 192, 200, 4, 15, 182, 192, 201, 194, 4, 0 })
  132. ' mov al,[ebp+8]
  133. ' ror al,4
  134. ' movzx eax,al
  135. ' leave
  136. ' retn 4
  137. 返回 (0)
复制代码

相关帖子

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则