设为首页收藏本站帮助中心
查看: 129|回复: 0
收起左侧

易语言实现 写到文件_追加 将字节集数据追加补充到指定文件尾部的位置 (返回逻辑型)

[复制链接]
发表于 2023-10-14 07:52:09 | 显示全部楼层 |阅读模式
1.png
  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. 删除文件 (“temp.txt”)
  8. 输出调试文本 (写到文件_追加 (“temp.txt”, 到字节集 (“Hello World!”)))
  9. 输出调试文本 (写到文件_追加 (“temp.txt”, 到字节集 (“中文测试”)))
  10. 信息框 (到文本 (读入文件 (“temp.txt”)), 0, , )

  11. .子程序 写到文件_追加, 逻辑型, 公开, 本命令用作将一个或数个字节集顺序追加到指定文件尾部的位置,文件原有内容保留。成功返回真,失败返回假。
  12. .参数 文件名, 文本型
  13. .参数 欲追加文件的数据, 字节集
  14. .局部变量 文件号, 整数型

  15. 文件号 = 打开文件 (文件名, #改写, #禁止读写)
  16. .如果真 (文件号 ≤ 0)
  17.     返回 (假)
  18. .如果真结束
  19. .如果真 (移动读写位置 (文件号, #文件尾, 0) = 假)
  20.     返回 (假)
  21. .如果真结束
  22. .如果真 (写出字节集 (文件号, 欲追加文件的数据) = 假)
  23.     返回 (假)
  24. .如果真结束
  25. 关闭文件 (文件号)
  26. 返回 (真)

复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则