设为首页收藏本站帮助中心
查看: 149|回复: 0
收起左侧

易语言实现将字节集数据、字节型数组转换成C语言源码 十六进制数组代码 (返回文本型)

[复制链接]
发表于 2023-7-19 16:12:07 | 显示全部楼层 |阅读模式
1.png
  1. .版本 2
  2. .常量 十六进制文本, "“0123456789ABCDEF”"
  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型

  5. _临时子程序 ()
  6. 返回 (0)

  7. .子程序 _临时子程序
  8. .局部变量 字节集, 字节集
  9. .局部变量 计数, 整数型
  10. .局部变量 字节型数组, 字节型, , "0"

  11. 字节集 = { 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16 }
  12. 信息框 (字节集_到C语言代码 (字节集, “temp”), 0, , )
  13. 字节型数组 = { 16, 15, 14, 13, 12, 11, 10 }
  14. 信息框 (字节型数组_到C语言代码 (字节型数组, “temp”), 0, , )


  15. .子程序 字节集_到C语言代码, 文本型, 公开
  16. .参数 字节集, 字节集
  17. .参数 变量名, 文本型
  18. .局部变量 文件号, 整数型
  19. .局部变量 字节集长度, 整数型
  20. .局部变量 返回值, 文本型
  21. .局部变量 计数, 整数型
  22. .局部变量 换行, 逻辑型

  23. 字节集长度 = 取字节集长度 (字节集)
  24. .如果真 (字节集长度 ≤ 0)
  25.     返回 (“”)
  26. .如果真结束
  27. 文件号 = 打开内存文件 ()
  28. 写出文本 (文件号, “unsigned char ” + 变量名 + “[” + 到文本 (字节集长度) + “] = {” + #换行符 + 字符 (9))
  29. .计次循环首 (字节集长度, 计数)
  30.     写出文本 (文件号, “0x”, 字节型_到十六进制文本 (字节集 [计数]))
  31.     .如果真 (字节集长度 ≠ 计数)
  32.         写出文本 (文件号, “,”)
  33.     .如果真结束
  34.     .如果 (计数 % 16 = 0)
  35.         换行 = 真
  36.         写出文本 (文件号, #换行符)
  37.         .如果真 (字节集长度 ≠ 计数)
  38.             写出文本 (文件号, 字符 (9))
  39.         .如果真结束

  40.     .否则
  41.         换行 = 假
  42.     .如果结束

  43. .计次循环尾 ()
  44. 写出文本 (文件号, 选择 (换行, “”, #换行符) + “};”)
  45. 移动读写位置 (文件号, 1, 0)
  46. 返回值 = 读入文本 (文件号, 取文件长度 (文件号))
  47. 返回 (返回值)


  48. .子程序 字节型数组_到C语言代码, 文本型, 公开
  49. .参数 字节型数组, 字节型, 数组
  50. .参数 变量名, 文本型

  51. 返回 (字节集_到C语言代码 (到字节集 (字节型数组), 变量名))


  52. .子程序 字节型_到十六进制文本, 文本型
  53. .参数 字节, 字节型

  54. 返回 (取文本中间 (#十六进制文本, 右移 (字节, 4) + 1, 1) + 取文本中间 (#十六进制文本, 位与 (字节, 15) + 1, 1))
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则