更改用户名CRC32解密回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行
查看: 148|回复: 0
收起左侧

易语言MASM汇编置入代码实现检测、判断是否为0字节空白文本型字符串 (返回逻辑型)

[复制链接]
发表于 2019-7-31 09:49:42 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册有礼

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 A, 文本型

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。


  9. 输出调试文本 (是否为空文本 (“”))
  10. 输出调试文本 (是否为空文本 (A))
  11. A = “”
  12. 输出调试文本 (是否为空文本 (A))
  13. 输出调试文本 (是否为空文本 (A + “1”))
  14. 输出调试文本 (是否为空文本 (A + A))
  15. 输出调试文本 (是否为空文本 (到文本 ({  })))
  16. A = 到文本 ({  })
  17. 输出调试文本 (是否为空文本 (A))
  18. 输出调试文本 (是否为空文本 (“1”))


  19. .子程序 是否为空文本, 逻辑型
  20. .参数 文本, 文本型

  21. 置入代码 ({ 139, 69, 8, 232, 18, 0, 0, 0, 128, 249, 1, 117, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 4, 0, 80, 139, 0, 11, 192, 117, 4, 177, 1, 235, 12, 138, 0, 10, 192, 117, 4, 177, 1, 235, 2, 50, 201, 88, 195 })
  22. ' mov eax,[ebp+8]
  23. ' call IS_TEXT_NULL
  24. ' .if cl == 1
  25. ' mov eax,1
  26. ' .elseif
  27. ' xor eax,eax
  28. ' .endif
  29. ' leave
  30. ' retn 4
  31. ' IS_TEXT_NULL: ;是否为空文本 参数1(字节集指针,EAX传入,由[EBP+n]返回) (CL寄存器返回,空为1,非空为0)
  32. ' push eax
  33. ' mov eax,[eax]
  34. ' .if eax == 0
  35. ' mov cl,1
  36. ' jmp IS_TEXT_NULL_END
  37. ' .endif
  38. ' mov al,[eax]
  39. ' .if al == 0
  40. ' mov cl,1
  41. ' jmp IS_TEXT_NULL_END
  42. ' .endif
  43. ' xor cl,cl
  44. ' IS_TEXT_NULL_END:
  45. ' pop eax
  46. ' ret

  47. 返回 (假)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册有礼

本版积分规则