设为首页收藏本站帮助中心
查看: 160|回复: 0
收起左侧

易语言实现改变位图高度(不改变宽度)将任意比例位图转换成3:4 三比四比例(返回逻辑型)

[复制链接]
发表于 2023-9-21 18:45:19 | 显示全部楼层 |阅读模式
输入图片:
in.png
转换结果:
out.png
  1. .版本 2
  2. .支持库 BmpOperate

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 输入, 位图
  9. .局部变量 输出, 位图

  10. 输入.载入文件 (“in.bmp”)
  11. .如果 (位图_到3比4 (输入, 输出, #绿色))
  12.     写到文件 (“out.bmp”, 输出.取位图数据 ())
  13. .否则
  14.     暂停 ()
  15. .如果结束


  16. .子程序 位图_到3比4, 逻辑型, 公开, 改变位图高度(不改变宽度)实现将位图比例转换成三比四,成功返回真,失败返回假
  17. .参数 输入, 位图, , 传入待处理的位图。
  18. .参数 输出, 位图, 参考, 位图转换结果将通过此变量传出。
  19. .参数 背景填充颜色, 整数型, , 位图处理后尺寸如果变大,新增的部分将用该颜色填充。
  20. .局部变量 宽, 整数型
  21. .局部变量 高, 整数型
  22. .局部变量 位深度, 整数型
  23. .局部变量 高2, 整数型

  24. 宽 = 输入.取宽度 ()
  25. 高 = 输入.取高度 ()
  26. 高2 = 宽 ÷ 3 × 4
  27. 位深度 = 输入.取位深度 ()
  28. .判断开始 (宽 ≤ 0 或 高 ≤ 0)
  29.     返回 (假)
  30. .判断 (输出.创建 (宽, 高2, 位深度, 背景填充颜色) = 假)
  31.     返回 (假)
  32. .判断 (输出.置横向分辨率 (输入.取横向分辨率 ()) = 假)
  33.     返回 (假)
  34. .判断 (输出.置纵向分辨率 (输入.取纵向分辨率 ()) = 假)
  35.     返回 (假)
  36. .判断 (输入.复制到 (0, 0, 宽, 高, 输出, 0, (高2 - 高) ÷ 2, ) = 假)
  37.     返回 (假)
  38. .默认

  39. .判断结束
  40. 返回 (真)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则