设为首页收藏本站帮助中心
查看: 32|回复: 0
收起左侧

易语言三角函数数学公式算法:sin(求正弦),cos(求余弦),tan(求正切)(返回双精度小数型)

[复制链接]
发表于 2024-2-1 16:44:21 | 显示全部楼层 |阅读模式
1.png
  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1
  4. .程序集变量 阶乘表, 双精度小数型, , "0"

  5. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码
  6. .局部变量 i, 整数型
  7. .局部变量 j, 双精度小数型

  8. i = 1
  9. j = 1
  10. .判断循环首 (真)
  11.     .如果真 (是否运算正确 (j) = 假)
  12.         跳出循环 ()
  13.     .如果真结束
  14.     j = j × i
  15.     i = i + 1
  16.     加入成员 (阶乘表, j)
  17. .判断循环尾 ()

  18. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  19. 返回 (0)  ' 可以根据您的需要返回任意数值

  20. .子程序 _临时子程序
  21. .局部变量 小数, 双精度小数型

  22. 置随机数种子 ()
  23. 小数 = 取随机数 (0, 32767) ÷ 32767 × #pi
  24. .如果真 (取随机数 (0, 1) = 1)
  25.     小数 = 0 - 小数
  26. .如果真结束
  27. 调试输出 (_sin (小数), 求正弦 (小数))
  28. 调试输出 (_cos (小数), 求余弦 (小数))
  29. 调试输出 (_tan (小数), 求正切 (小数))

  30. .子程序 _sin, 双精度小数型, 公开
  31. .参数 x, 双精度小数型
  32. .局部变量 i, 整数型
  33. .局部变量 y, 双精度小数型
  34. .局部变量 j, 双精度小数型

  35. i = 3
  36. y = x
  37. j = 6
  38. .判断循环首 (真)
  39.     j = 阶乘表 [i]
  40.     .如果真 (是否运算正确 (j) = 假)
  41.         跳出循环 ()
  42.     .如果真结束
  43.     y = 0 - (y - 求次方 (x, i) ÷ j)
  44.     i = i + 2
  45. .判断循环尾 ()
  46. 返回 (y)


  47. .子程序 _cos, 双精度小数型, 公开
  48. .参数 x, 双精度小数型

  49. 返回 (_sin (#pi ÷ 2 + x))


  50. .子程序 _tan, 双精度小数型, 公开
  51. .参数 x, 双精度小数型

  52. 返回 (_sin (x) ÷ _cos (x))
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则