设为首页收藏本站帮助中心
查看: 25|回复: 0
收起左侧

易语言实现 取随机百家姓 随机起名器软件 中文姓氏姓名人名生成器源码 (返回文本型)

[复制链接]
发表于 2024-2-5 20:16:12 | 显示全部楼层 |阅读模式
1.png
  1. .版本 2

  2. .程序集 程序集1
  3. .程序集变量 百家姓, 文本型
  4. .程序集变量 百家姓字节, 整数型

  5. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码

  6. 置随机数种子 ()

  7. 百家姓 = “赵钱孙李周吴郑王冯陈褚卫蒋沈韩杨朱秦尤许何吕施张孔曹严华金魏陶姜戚谢邹喻柏水窦章云苏潘葛奚范彭郎鲁韦昌马苗凤花方俞任袁柳酆鲍史唐费廉岑薛雷贺倪汤滕殷罗毕郝邬安常乐于时傅皮卞齐康伍余元卜顾孟平黄和穆萧尹姚邵湛汪祁毛禹狄米贝明臧计伏成戴谈宋茅庞熊纪舒屈项祝董梁杜阮蓝闵席季麻强贾路娄危江童颜郭梅盛林刁钟徐邱骆高夏蔡田樊胡凌霍虞万支柯昝管卢莫柯房裘缪干解应宗丁宣贲邓郁单杭洪包诸左石崔吉钮龚程嵇邢滑裴陆荣翁荀羊于惠甄曲家封芮羿储靳汲邴糜松井段富巫乌焦巴弓牧隗山谷车侯宓蓬全郗班仰秋仲伊宫宁仇栾暴甘钭历戎祖武符刘景詹束龙叶幸司韶郜黎蓟溥印宿白怀蒲邰从鄂索咸籍赖卓蔺屠蒙池乔阳郁胥能苍双闻莘党翟谭贡劳逄姬申扶堵冉宰郦雍却璩桑桂濮牛寿通边扈燕冀浦尚农温别庄晏柴瞿阎充慕连茹习宦艾鱼容向古易慎戈廖庾终暨居衡步都耿满弘匡国文寇广禄阙东欧殳沃利蔚越夔隆师巩厍聂晁勾敖融冷訾辛阚那简饶空曾毋沙乜养鞠须丰巢关蒯相查后荆红游竺权逮盍益桓公”
  8. 百家姓字节 = 取文本长度 (百家姓)

  9. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  10. 返回 (0)  ' 可以根据您的需要返回任意数值

  11. .子程序 _临时子程序
  12. .局部变量 文本, 文本型

  13. .计次循环首 (100, )
  14.     文本 = 文本 + 取随机姓名 (真) + “,”
  15. .计次循环尾 ()
  16. 信息框 (文本, 0, “随机姓名”, )

  17. .子程序 取随机姓氏, 文本型, 公开
  18. .局部变量 随机, 短整数型

  19. 随机 = 取随机数 (1, 百家姓字节)
  20. .如果真 (位与 (随机, 1) = 0)
  21.     随机 = 随机 - 1
  22. .如果真结束
  23. 返回 (取文本中间 (百家姓, 随机, 2))

  24. .子程序 取随机姓名, 文本型, 公开
  25. .参数 禁用多音字, 逻辑型, 可空, 不含姓氏
  26. .局部变量 长度, 整数型
  27. .局部变量 字节, 字节集
  28. .局部变量 汉字, 文本型
  29. .局部变量 发音, 整数型
  30. .局部变量 姓名, 文本型

  31. 长度 = 取随机数 (1, 2)
  32. 姓名 = 取随机姓氏 ()
  33. 字节 = 取空白字节集 (2)
  34. .计次循环首 (长度, )
  35.     .循环判断首 ()
  36.         字节 [1] = 取随机数 (128, 255)
  37.         字节 [2] = 取随机数 (1, 255)
  38.         汉字 = 到文本 (字节)
  39.         发音 = 取发音数目 (汉字)
  40.         .如果 (禁用多音字)
  41.             .如果真 (发音 = 1)
  42.                 跳出循环 ()
  43.             .如果真结束

  44.         .否则
  45.             .如果真 (发音 > 0)
  46.                 跳出循环 ()
  47.             .如果真结束

  48.         .如果结束

  49.     .循环判断尾 (真)
  50.     姓名 = 姓名 + 汉字
  51. .计次循环尾 ()
  52. 返回 (姓名)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则