设为首页收藏本站帮助中心
查看: 131|回复: 0
收起左侧

易语言 已知年份求十二生肖中的年是什么年 12生肖计算算法公式源码

[复制链接]
发表于 2023-8-29 21:00:55 | 显示全部楼层 |阅读模式
1.png
  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型
  4. .局部变量 年, 文本型

  5. .如果真 (输入框 (, “请输入年份:”, 到文本 (取年份 (取现行时间 ())), 年, #输入整数, ) = 假)
  6.     返回 (0)
  7. .如果真结束
  8. 信息框 (年算生肖 (到整数 (年)), 0, , )
  9. 返回 (0)  ' 可以根据您的需要返回任意数值

  10. .子程序 年算生肖, 文本型, 公开, 失败返回空文本
  11. .参数 年, 整数型, , 大于0的整数
  12. .局部变量 生肖, 文本型, , "0"

  13. .如果真 (年 < 0)
  14.     返回 (“”)
  15. .如果真结束
  16. 生肖 = { “猴”, “鸡”, “狗”, “猪”, “鼠”, “牛”, “虎”, “兔”, “龙”, “蛇”, “马”, “羊” }
  17. 返回 (生肖 [年 % 12 + 1])
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则