设为首页收藏本站帮助中心
查看: 564|回复: 0
收起左侧

易语言MASM置入代码实现短整数型/长整数型/日期时间型的快速不等于比较 (返回逻辑型)

[复制链接]
发表于 2019-9-22 18:00:23 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (快速不等于_短整数型 (12345, 23456))
  9. 输出调试文本 (快速不等于_长整数型 (1, 1.234567890123e+018))
  10. 输出调试文本 (快速不等于_日期时间型 ([2019年12月31日1时1分1秒], [2019年12月31日1时1分2秒]))


  11. .子程序 快速不等于_短整数型, 逻辑型, 公开
  12. .参数 被比较值, 短整数型
  13. .参数 比较值, 短整数型

  14. 置入代码 ({ 102, 139, 69, 8, 102, 59, 69, 12, 116, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 8, 0 })
  15. ' mov ax,[ebp+8]
  16. ' .if ax != [ebp+12]
  17. ' mov eax,1
  18. ' .elseif
  19. ' xor eax,eax
  20. ' .endif
  21. ' leave
  22. ' retn 8

  23. 返回 (假)


  24. .子程序 快速不等于_长整数型, 逻辑型, 公开
  25. .参数 被比较值, 长整数型
  26. .参数 比较值, 长整数型

  27. 置入代码 ({ 82, 139, 69, 8, 139, 85, 12, 59, 69, 16, 117, 9, 59, 85, 20, 117, 4, 51, 192, 235, 5, 184, 1, 0, 0, 0, 90, 201, 194, 16, 0 })
  28. ' push edx
  29. ' mov eax,[ebp+8]
  30. ' mov edx,[ebp+12]
  31. ' .if eax == [ebp+16] && edx == [ebp+20]
  32. ' xor eax,eax
  33. ' .else
  34. ' mov eax,1
  35. ' .endif
  36. ' pop edx
  37. ' leave
  38. ' retn 16

  39. 返回 (假)

  40. .子程序 快速不等于_日期时间型, 逻辑型, 公开
  41. .参数 被比较值, 日期时间型
  42. .参数 比较值, 日期时间型

  43. 置入代码 ({ 82, 139, 69, 8, 139, 85, 12, 59, 69, 16, 117, 9, 59, 85, 20, 117, 4, 51, 192, 235, 5, 184, 1, 0, 0, 0, 90, 201, 194, 16, 0 })
  44. ' push edx
  45. ' mov eax,[ebp+8]
  46. ' mov edx,[ebp+12]
  47. ' .if eax == [ebp+16] && edx == [ebp+20]
  48. ' xor eax,eax
  49. ' .else
  50. ' mov eax,1
  51. ' .endif
  52. ' pop edx
  53. ' leave
  54. ' retn 16

  55. 返回 (假)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则