设为首页收藏本站帮助中心
查看: 305|回复: 1
收起左侧

位图增强模块V1.2使用例程之随机渐变颜色屏保

[复制链接]
发表于 2017-8-14 17:06:03 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
  1. .版本 2
  2. .支持库 spec

  3. .程序集 窗口程序集_启动窗口

  4. .子程序 __启动窗口_创建完毕
  5. .局部变量 开始颜色, 整数型
  6. .局部变量 结束颜色, 整数型
  7. .局部变量 颜色表, 整数型, , "0"
  8. .局部变量 计数, 整数型

  9. 置错误提示管理 (&错误提示)
  10. 置随机数种子 ()

  11. 左边 = 0
  12. 顶边 = 0
  13. 宽度 = 取屏幕宽度 ()
  14. 高度 = 取屏幕高度 ()
  15. 开始颜色 = 取颜色值 (取随机数 (0, 255), 取随机数 (0, 255), 取随机数 (0, 255))
  16. 结束颜色 = 取颜色值 (取随机数 (0, 255), 取随机数 (0, 255), 取随机数 (0, 255))
  17. 可视 = 真
  18. 生成颜色渲染数据 (开始颜色, 结束颜色, 256, 颜色表)
  19. .判断循环首 (真)
  20.     .计次循环首 (256, 计数)
  21.         底色 = 颜色表 [计数]
  22.         延迟 (1)
  23.     .计次循环尾 ()
  24.     开始颜色 = 结束颜色
  25.     结束颜色 = 取颜色值 (取随机数 (0, 255), 取随机数 (0, 255), 取随机数 (0, 255))
  26.     生成颜色渲染数据 (开始颜色, 结束颜色, 256, 颜色表)

  27. .判断循环尾 ()



  28. .子程序 错误提示, 逻辑型
  29. .参数 文本, 文本型
  30. .参数 整数, 整数型

  31. 返回 (真)


复制代码



相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则