设为首页收藏本站帮助中心
查看: 697|回复: 0
收起左侧

易语言实现位图的反色/负片/底片/底色滤镜 (返回位图)

[复制链接]
发表于 2021-3-21 22:33:35 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
输入图片:
in.png
滤镜效果:
out.png
  1. .版本 2
  2. .支持库 BmpOperate

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 位图, 位图

  9. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  10. .如果真 (位图.载入文件 (“in.bmp”) = 假)
  11.     信息框 (位图.取错误信息 (), 0, , )
  12.     结束 ()
  13. .如果真结束
  14. 写到文件 (“out.bmp”, 位图_反色 (位图).取位图数据 ())


  15. .子程序 位图_反色, 位图, 公开
  16. .参数 位图, 位图
  17. .局部变量 宽, 整数型
  18. .局部变量 高, 整数型
  19. .局部变量 X, 整数型
  20. .局部变量 Y, 整数型
  21. .局部变量 返回值, 位图

  22. 宽 = 位图.取宽度 ()
  23. 高 = 位图.取高度 ()
  24. 返回值.创建 (宽, 高, 位图.取位深度 (), )
  25. .变量循环首 (0, 宽 - 1, 1, X)
  26.     .变量循环首 (0, 高 - 1, 1, Y)
  27.         返回值.置某点颜色 (X, Y, 位异或 (位图.取某点颜色 (X, Y), 16777215))
  28.     .变量循环尾 ()
  29. .变量循环尾 ()
  30. 返回 (返回值)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则