更改用户名CRC32解密回帖奖励召回投票记录删除领夜猫子帮助中心 本站已运行

易语言MASM置入代码实现将一个文本型数组所有成员合并相加拼接在一起 (返回文本型)

[复制链接]
查看145 | 回复0 | 2019-8-31 19:05:33 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册有礼

x

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  9. 调试输出 (文本型数组_合并 ({ “123”, “456”, “Hello World!”, “中文测试” }))


  10. .子程序 文本型数组_合并, 文本型
  11. .参数 文本型数组, 文本型, 数组
  12. .局部变量 数组成员数, 整数型
  13. .局部变量 文本缓存, 字节型, , "0"

  14. 数组成员数 = 0
  15. 置入代码 ({ 235, 24, 80, 83, 139, 208, 138, 24, 10, 219, 117, 2, 235, 3, 64, 235, 245, 139, 216, 135, 218, 43, 211, 91, 88, 195, 80, 83, 81, 82, 86, 87, 139, 117, 8, 139, 54, 139, 126, 4, 131, 198, 8, 51, 201, 51, 219, 235, 11, 139, 4, 142, 232, 201, 255, 255, 255, 3, 218, 65, 59, 207, 114, 241, 67, 137, 93, 252, 95, 94, 90, 89, 91, 88 })
  16. ' jmp MAIN
  17. ' TEXT_LEN: ;EAX:文本指针 EDX(返回):文本长度
  18. ' push eax
  19. ' push ebx
  20. ' mov edx,eax
  21. ' .while 1
  22. ' mov bl,[eax]
  23. ' .if !bl
  24. ' .break
  25. ' .endif
  26. ' inc eax
  27. ' .endw
  28. ' mov ebx,eax
  29. ' xchg ebx,edx
  30. ' sub edx,ebx
  31. ' pop ebx
  32. ' pop eax
  33. ' ret
  34. ' MAIN:
  35. ' push eax
  36. ' push ebx
  37. ' push ecx
  38. ' push edx
  39. ' push esi
  40. ' push edi
  41. ' mov esi,[ebp+8]
  42. ' mov esi,[esi]
  43. ' mov edi,[esi+4]
  44. ' add esi,8
  45. ' xor ecx,ecx
  46. ' xor ebx,ebx
  47. ' .while ecx < edi
  48. ' mov eax,[esi+ecx*4]
  49. ' call TEXT_LEN
  50. ' add ebx,edx
  51. ' inc ecx
  52. ' .endw
  53. ' inc ebx
  54. ' mov [ebp-4],ebx
  55. ' pop edi
  56. ' pop esi
  57. ' pop edx
  58. ' pop ecx
  59. ' pop ebx
  60. ' pop eax

  61. 重定义数组 (文本缓存, 真, 数组成员数)
  62. 置入代码 ({ 83, 81, 82, 86, 87, 139, 117, 8, 139, 54, 139, 126, 4, 131, 198, 8, 51, 201, 139, 93, 248, 131, 195, 8, 235, 20, 139, 4, 142, 138, 16, 10, 210, 117, 4, 235, 8, 235, 2, 136, 19, 64, 67, 235, 240, 65, 59, 207, 114, 232, 139, 69, 248, 131, 192, 8, 91, 89, 90, 94, 95, 201, 194, 4, 0 })
  63. ' push ebx
  64. ' push ecx
  65. ' push edx
  66. ' push esi
  67. ' push edi
  68. ' mov esi,[ebp+8]
  69. ' mov esi,[esi]
  70. ' mov edi,[esi+4]
  71. ' add esi,8
  72. ' xor ecx,ecx
  73. ' mov ebx,[ebp-8]
  74. ' add ebx,8
  75. ' .while ecx < edi
  76. ' mov eax,[esi+ecx*4]
  77. ' .while 1
  78. ' mov dl,[eax]
  79. ' .if dl == 0
  80. ' .break
  81. ' .else
  82. ' mov [ebx],dl
  83. ' .endif
  84. ' inc eax
  85. ' inc ebx
  86. ' .endw
  87. ' inc ecx
  88. ' .endw
  89. ' mov eax,[ebp-8]
  90. ' add eax,8
  91. ' pop ebx
  92. ' pop ecx
  93. ' pop edx
  94. ' pop esi
  95. ' pop edi
  96. ' leave
  97. ' retn 4



  98. 返回 (“”)
复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册有礼

本版积分规则