设为首页收藏本站帮助中心
查看: 417|回复: 0
收起左侧

易语言MASM置入代码实现计算字节集(字节型数组)的校验和,所有字节加起来 (返回字节型)

[复制链接]
发表于 2019-11-22 21:12:47 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (字节集_取校验和 ({ 1, 2, 3, 4, 5, 6, 7, 8, 9, 10 }))  ' 返回=1+2+3+4+5+6+7+8+9+10
  9. 输出调试文本 (字节型数组_取校验和 ({ 1, 2, 3, 4, 5, 6, 7, 8, 9, 10 }))  ' 返回=1+2+3+4+5+6+7+8+9+10

  10. .子程序 字节集_取校验和, 字节型, 公开
  11. .参数 数据, 字节集

  12. 置入代码 ({ 83, 81, 82, 139, 69, 8, 11, 192, 117, 2, 235, 31, 139, 0, 11, 192, 117, 2, 235, 23, 139, 88, 4, 131, 192, 8, 51, 201, 50, 210, 235, 4, 2, 20, 8, 65, 59, 203, 114, 248, 15, 182, 194, 90, 89, 91, 201, 194, 4, 0 })
  13. ' push ebx
  14. ' push ecx
  15. ' push edx
  16. ' mov eax,[ebp+8]
  17. ' .if eax == 0
  18. ' jmp ASM_END
  19. ' .endif
  20. ' mov eax,[eax]
  21. ' .if eax == 0
  22. ' jmp ASM_END
  23. ' .endif
  24. ' mov ebx,[eax+4]
  25. ' add eax,8
  26. ' xor ecx,ecx
  27. ' xor dl,dl
  28. ' .while ecx<ebx
  29. ' add dl,[ecx+eax]
  30. ' inc ecx
  31. ' .endw
  32. ' movzx eax,dl
  33. ' ASM_END:
  34. ' pop edx
  35. ' pop ecx
  36. ' pop ebx
  37. ' leave
  38. ' retn 4

  39. 返回 (0)

  40. .子程序 字节型数组_取校验和, 字节型, 公开
  41. .参数 字节型数组, 字节型, 数组

  42. 置入代码 ({ 83, 81, 82, 139, 69, 8, 11, 192, 117, 2, 235, 31, 139, 0, 11, 192, 117, 2, 235, 23, 139, 88, 4, 131, 192, 8, 51, 201, 50, 210, 235, 4, 2, 20, 8, 65, 59, 203, 114, 248, 15, 182, 194, 90, 89, 91, 201, 194, 4, 0 })
  43. ' push ebx
  44. ' push ecx
  45. ' push edx
  46. ' mov eax,[ebp+8]
  47. ' .if eax == 0
  48. ' jmp ASM_END
  49. ' .endif
  50. ' mov eax,[eax]
  51. ' .if eax == 0
  52. ' jmp ASM_END
  53. ' .endif
  54. ' mov ebx,[eax+4]
  55. ' add eax,8
  56. ' xor ecx,ecx
  57. ' xor dl,dl
  58. ' .while ecx<ebx
  59. ' add dl,[ecx+eax]
  60. ' inc ecx
  61. ' .endw
  62. ' movzx eax,dl
  63. ' ASM_END:
  64. ' pop edx
  65. ' pop ecx
  66. ' pop ebx
  67. ' leave
  68. ' retn 4

  69. 返回 (0)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则