设为首页收藏本站帮助中心
查看: 148|回复: 1
收起左侧

易语言MASM置入代码实现获取文本型第3个斜杠或反斜杠的位置 (未找到返回0,返回整数型)

[复制链接]
发表于 2020-1-15 23:11:32 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序


  7. 输出调试文本 (取第3个斜杠位置 (“http://127.0.0.1/index.php”))

  8. 输出调试文本 (取第3个斜杠位置 (“//”))
  9. 输出调试文本 (取第3个斜杠位置 (“///”))
  10. 输出调试文本 (取第3个斜杠位置 (“////”))





  11. .子程序 取第3个斜杠位置, 整数型
  12. .参数 URL, 文本型

  13. 置入代码 ({ 83, 81, 51, 201, 139, 69, 8, 11, 192, 117, 2, 235, 48, 139, 0, 11, 192, 117, 2, 235, 40, 50, 255, 138, 24, 10, 219, 117, 6, 51, 192, 235, 28, 235, 22, 128, 251, 47, 116, 5, 128, 251, 92, 117, 12, 254, 199, 128, 255, 3, 117, 5, 141, 65, 1, 235, 4, 65, 64, 235, 218, 89, 91, 201, 194, 4, 0 })
  14. ' push ebx
  15. ' push ecx
  16. ' xor ecx,ecx
  17. ' mov eax,[ebp+8]
  18. ' .if eax == 0
  19. ' jmp ASM_END
  20. ' .endif
  21. ' mov eax,[eax]
  22. ' .if eax == 0
  23. ' jmp ASM_END
  24. ' .endif
  25. ' xor bh,bh
  26. ' .while 1
  27. ' mov bl,[eax]
  28. ' .if bl == 0
  29. ' xor eax,eax
  30. ' jmp ASM_END
  31. ' .elseif bl == '/' || bl == '\'
  32. ' inc bh
  33. ' .if bh == 3
  34. ' lea eax,[ecx+1]
  35. ' jmp ASM_END
  36. ' .endif
  37. ' .endif
  38. ' inc ecx
  39. ' inc eax
  40. ' .endw
  41. ' ASM_END:
  42. ' pop ecx
  43. ' pop ebx
  44. ' leave
  45. ' retn 4

  46. 返回 (0)

复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则