设为首页收藏本站帮助中心
查看: 638|回复: 0
收起左侧

易语言MASM置入代码将文本型文件名中的不可用非法字符全部替换为下划线 (无返回值)

[复制链接]
发表于 2020-4-19 20:51:51 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 文件名, 文本型

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  9. 文件名 = “Hello World! ?|<>/\ 中文测试&.txt” + #引号
  10. 文件名_非法字符替换为下划线 (文件名)
  11. 信息框 (文件名, 0, , )

  12. .子程序 文件名_非法字符替换为下划线, , 公开, 将文件名中不可用的字符全部替换为下划线
  13. .参数 文件名, 文本型, 参考, 不包含路径,提供文本型变量

  14. 置入代码 ({ 80, 83, 139, 69, 8, 11, 192, 117, 2, 235, 75, 139, 0, 11, 192, 117, 2, 235, 67, 138, 24, 10, 219, 117, 4, 235, 59, 235, 54, 128, 251, 31, 118, 45, 128, 251, 34, 116, 40, 128, 251, 42, 116, 35, 128, 251, 47, 116, 30, 128, 251, 58, 116, 25, 128, 251, 60, 116, 20, 128, 251, 62, 116, 15, 128, 251, 63, 116, 10, 128, 251, 92, 116, 5, 128, 251, 124, 117, 4, 179, 95, 136, 24, 64, 235, 189, 91, 88 })
  15. ' push eax
  16. ' push ebx
  17. ' mov eax,[ebp+8]
  18. ' .if eax == 0
  19. ' jmp ASM_END
  20. ' .endif
  21. ' mov eax,[eax]
  22. ' .if eax == 0
  23. ' jmp ASM_END
  24. ' .endif
  25. ' .while 1
  26. ' mov bl,[eax]
  27. ' .if bl == 0
  28. ' .break
  29. ' .elseif bl <= 31 || bl == 34 || bl == 42 || bl == 47 || bl == 58 || bl == 60 || bl == 62 || bl == 63 || bl == 92 || bl == 124
  30. ' mov bl,95
  31. ' mov [eax],bl
  32. ' .endif
  33. ' inc eax
  34. ' .endw
  35. ' ASM_END:
  36. ' pop ebx
  37. ' pop eax

复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则