设为首页收藏本站帮助中心
查看: 219|回复: 0
收起左侧

易语言MASM汇编置入代码实现C51的 _testbit_(); 函数 (返回逻辑型)

[复制链接]
发表于 2020-8-26 22:27:50 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序
  8. .局部变量 bit, 逻辑型

  9. bit = 真
  10. 输出调试文本 (_testbit_ (bit))
  11. 输出调试文本 (bit)

  12. 输出调试文本 (_testbit_ (bit))
  13. 输出调试文本 (bit)
  14. bit = 真
  15. .循环判断首 ()
  16.     调试输出 (“@”)
  17. .循环判断尾 (_testbit_ (bit))

  18. .子程序 _testbit_, 逻辑型, 公开, 如果bit为真,则返回真,并将bit置假,否则返回假
  19. .参数 bit, 逻辑型, 参考, 必须是逻辑型变量,不得使用常量或表达式,否则会出错

  20. 置入代码 ({ 83, 81, 139, 93, 8, 185, 1, 0, 0, 0, 33, 11, 139, 3, 51, 201, 137, 11, 89, 91, 201, 194, 4, 0 })
  21. ' push ebx
  22. ' push ecx
  23. ' mov ebx,[ebp+8]
  24. ' mov ecx,1
  25. ' and [ebx],ecx
  26. ' mov eax,[ebx]
  27. ' xor ecx,ecx
  28. ' mov [ebx],ecx
  29. ' pop ecx
  30. ' pop ebx
  31. ' leave
  32. ' retn 4
  33. 返回 (假)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则