设为首页收藏本站帮助中心
查看: 277|回复: 2
收起左侧

易语言MASM置入代码实现将字节型/短整数型/整数型转换到逻辑型 (0返回假,非0返回真)

[复制链接]
发表于 2020-8-29 20:48:37 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
本帖最后由 EAX 于 2020-8-30 19:36 编辑

1.png

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序

  8. 调试输出 (到逻辑_字节型 (0), 到逻辑_字节型 (1), 到逻辑_字节型 (-2))
  9. 调试输出 (到逻辑_短整数型 (0), 到逻辑_短整数型 (1), 到逻辑_短整数型 (-2))
  10. 调试输出 (到逻辑_整数型 (0), 到逻辑_整数型 (1), 到逻辑_整数型 (-2))


  11. .子程序 到逻辑_字节型, 逻辑型, 公开, 0返回假,非0返回真
  12. .参数 值, 字节型

  13. 置入代码 ({ 138, 69, 8, 10, 192, 116, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 4, 0 })
  14. ' mov al,[ebp+8]
  15. ' .if al
  16. ' mov eax,1
  17. ' .else
  18. ' xor eax,eax
  19. ' .endif
  20. ' leave
  21. ' retn 4
  22. 返回 (假)

  23. .子程序 到逻辑_短整数型, 逻辑型, 公开, 0返回假,非0返回真
  24. .参数 值, 短整数型

  25. 置入代码 ({ 102, 139, 69, 8, 102, 11, 192, 116, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 201, 194, 4, 0 })
  26. ' mov ax,[ebp+8]
  27. ' .if ax
  28. ' mov eax,1
  29. ' .else
  30. ' xor eax,eax
  31. ' .endif
  32. ' leave
  33. ' retn 4
  34. 返回 (假)

  35. .子程序 到逻辑_整数型, 逻辑型, 公开, 0返回假,非0返回真
  36. .参数 值, 整数型

  37. 置入代码 ({ 139, 69, 8, 11, 192, 116, 7, 184, 1, 0, 0, 0, 235, 0, 201, 194, 4, 0 })
  38. ' mov eax,[ebp+8]
  39. ' .if eax
  40. ' mov eax,1
  41. ' .else
  42. ' .endif
  43. ' leave
  44. ' retn 4
  45. 返回 (假)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

发表于 2020-8-30 23:27:53 | 显示全部楼层

网络问题,刷新下就好了
这个小可爱很神秘,什么都没留下
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则