设为首页收藏本站帮助中心
查看: 312|回复: 0
收起左侧

易语言MASM置入代码检测整数型/子程序指针/小数型/短整数型是否大于等于0(返回逻辑型)

[复制链接]
发表于 2020-9-6 22:22:57 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2
  2. .支持库 spec

  3. .程序集 程序集1

  4. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  5. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  6. 返回 (0)  ' 可以根据您的需要返回任意数值

  7. .子程序 _临时子程序

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  9. 调试输出 (整数型_是否大于等于0 (0), 整数型_是否大于等于0 (-1), 整数型_是否大于等于0 (2))
  10. 调试输出 (小数型_是否大于等于0 (0), 小数型_是否大于等于0 (-0.01), 小数型_是否大于等于0 (111))
  11. 调试输出 (短整数型_是否大于等于0 (0), 短整数型_是否大于等于0 (-1), 小数型_是否大于等于0 (111))

  12. .子程序 整数型_是否大于等于0, 逻辑型, 公开
  13. .参数 值, 整数型

  14. 置入代码 ({ 139, 69, 8, 61, 0, 0, 0, 128, 114, 4, 51, 192, 235, 5, 184, 1, 0, 0, 0, 201, 194, 4, 0 })
  15. ' mov eax,[ebp+8]
  16. ' .if eax >= 80000000H
  17. ' xor eax,eax
  18. ' .elseif
  19. ' mov eax,1
  20. ' .endif
  21. ' leave
  22. ' retn 4
  23. 返回 (假)

  24. .子程序 小数型_是否大于等于0, 逻辑型, 公开
  25. .参数 值, 小数型

  26. 置入代码 ({ 139, 69, 8, 61, 0, 0, 0, 128, 114, 4, 51, 192, 235, 5, 184, 1, 0, 0, 0, 201, 194, 4, 0 })
  27. ' mov eax,[ebp+8]
  28. ' .if eax >= 80000000H
  29. ' xor eax,eax
  30. ' .elseif
  31. ' mov eax,1
  32. ' .endif
  33. ' leave
  34. ' retn 4
  35. 返回 (假)

  36. .子程序 子程序指针_是否大于等于0, 逻辑型, 公开,  
  37. .参数 值, 子程序指针

  38. 置入代码 ({ 139, 69, 8, 61, 0, 0, 0, 128, 114, 4, 51, 192, 235, 5, 184, 1, 0, 0, 0, 201, 194, 4, 0 })
  39. ' mov eax,[ebp+8]
  40. ' .if eax >= 80000000H
  41. ' xor eax,eax
  42. ' .elseif
  43. ' mov eax,1
  44. ' .endif
  45. ' leave
  46. ' retn 4
  47. 返回 (假)

  48. .子程序 短整数型_是否大于等于0, 逻辑型, 公开
  49. .参数 值, 短整数型

  50. 置入代码 ({ 102, 139, 69, 8, 102, 61, 0, 128, 114, 4, 51, 192, 235, 5, 184, 1, 0, 0, 0, 201, 194, 4, 0 })
  51. ' mov ax,[ebp+8]
  52. ' .if ax >= 8000H
  53. ' xor eax,eax
  54. ' .elseif
  55. ' mov eax,1
  56. ' .endif
  57. ' leave
  58. ' retn 4

  59. 返回 (假)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则