设为首页收藏本站帮助中心
查看: 42|回复: 0
收起左侧

易语言MASM置入代码判断日期时间型是否为100年1月1日或1899年12月30日 (返回逻辑型)

[复制链接]
发表于 2020-12-31 09:07:42 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. 输出调试文本 (日期时间型_是否为100年1月1日或1899年12月30日 ([100年1月1日]))
  8. 输出调试文本 (日期时间型_是否为100年1月1日或1899年12月30日 ([1899年12月30日]))
  9. 输出调试文本 (日期时间型_是否为100年1月1日或1899年12月30日 ([2020年12月31日]))


  10. .子程序 日期时间型_是否为100年1月1日或1899年12月30日, 逻辑型, 公开
  11. .参数 日期时间, 日期时间型

  12. 置入代码 ({ 82, 139, 69, 8, 139, 85, 12, 11, 192, 117, 4, 11, 210, 116, 12, 11, 192, 117, 15, 129, 250, 52, 16, 36, 193, 117, 7, 184, 1, 0, 0, 0, 235, 2, 51, 192, 90, 201, 194, 8, 0 })
  13. ' push edx
  14. ' mov eax,[ebp+8]
  15. ' mov edx,[ebp+12]
  16. ' .if (eax == 0 && edx == 0) || (eax == 0 && edx == 0C1241034H)
  17. ' mov eax,1
  18. ' .elseif
  19. ' xor eax,eax
  20. ' .endif
  21. ' pop edx
  22. ' leave
  23. ' retn 8
  24. 返回 (假)

复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则