设为首页收藏本站帮助中心
查看: 14|回复: 0
收起左侧

易语言MASM置入代码实现取文本型字符串的第1个字 (自动识别中英文1~2字节,无返回值)

[复制链接]
发表于 5 天前 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序
  7. .局部变量 文本, 文本型

  8. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  9. 文本 = “Hello World! 中文测试”
  10. 文本型_取第一字 (文本)
  11. 输出调试文本 (文本)
  12. 文本 = “易语言”
  13. 取第一字 (文本)
  14. 输出调试文本 (文本)


  15. .子程序 文本型_取第一字, , 公开, 取字符串的第1个字 (第1字节大于等于128则截取前2字节,否则1字节)
  16. .参数 字符串, 文本型, 参考, 必须提供文本型变量

  17. 置入代码 ({ 80, 83, 139, 69, 8, 11, 192, 117, 2, 235, 29, 139, 0, 11, 192, 117, 2, 235, 21, 179, 128, 50, 255, 56, 24, 114, 10, 56, 120, 1, 116, 8, 136, 120, 2, 235, 3, 136, 120, 1, 91, 88 })
  18. ' push eax
  19. ' push ebx
  20. ' mov eax,[ebp+8]
  21. ' .if eax == 0
  22. ' jmp ASM_END
  23. ' .endif
  24. ' mov eax,[eax]
  25. ' .if eax == 0
  26. ' jmp ASM_END
  27. ' .endif
  28. ' mov bl,128
  29. ' xor bh,bh
  30. ' .if [eax] >= bl
  31. ' .if [eax+1] != bh
  32. ' mov [eax+2],bh
  33. ' .endif
  34. ' .elseif
  35. ' mov [eax+1],bh
  36. ' .endif
  37. ' ASM_END:
  38. ' pop ebx
  39. ' pop eax

复制代码

相关帖子

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则