设为首页收藏本站帮助中心
查看: 48|回复: 1
收起左侧

易语言实现将文本型字符串或字节集数据写入临时文件并用记事本程序打开 (返回逻辑型)

[复制链接]
发表于 2020-10-17 18:36:53 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?加入我们

x
1.png

  1. .版本 2

  2. .程序集 程序集1

  3. .子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码


  4. _临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
  5. 返回 (0)  ' 可以根据您的需要返回任意数值

  6. .子程序 _临时子程序

  7. ' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
  8. 输出调试文本 (文本型_记事本打开 (“Hello World!”))

  9. .子程序 文本型_记事本打开, 逻辑型, 公开, 将文本型字符串写入临时目录,然后用记事本打开,成功返回真失败返回假
  10. .参数 文本型, 文本型

  11. 返回 (字节集_记事本打开 (到字节集 (文本型)))

  12. .子程序 字节集_记事本打开, 逻辑型, 公开, 将字节集数据写入临时目录,然后用记事本打开,成功返回真失败返回假
  13. .参数 字节集, 字节集
  14. .局部变量 临时文件名, 文本型

  15. 临时文件名 = 取临时文件名 ()
  16. .判断开始 (写到文件 (临时文件名, 字节集) = 假)
  17.     返回 (假)
  18. .判断 (运行 (“notepad ” + #引号 + 临时文件名 + #引号, 假, ) = 假)
  19.     返回 (假)
  20. .默认

  21. .判断结束
  22. 返回 (真)
复制代码

相关帖子

这个小可爱很神秘,什么都没留下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 加入我们

本版积分规则